0

Recently, I received an Email regarding an issue in our Salesforce Production org. Error message:

Error Occurred During Flow "PSA_Project_End_Date_Changed": The flow tried to update these records: null.

The flow tried to update these records: null. This error occurred: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY: MyApexTrigger: System.LimitException: Apex CPU time limit exceeded. You can look up ExceptionCode values in the SOAP API Developer Guide.

There is no Flow by this name. When I searched this in FlowDefinition, I did find that with the same 'DeveloperName' and 'FullName'. But, when I look in Process Builder, there is no Process Builder by the name.

Update: Tried using Workbench. I found this in FLow Definition but couldn't locate this in Frontend(a place where I can see what it does).

  • 1
    Did you also check Flow in the setup menu? It could be a Process Builder or a Visual Flow. – Charles T Aug 13 '18 at 12:37
  • 1
    Verify your flow once using workbench.You can find both flows and processes using Workbench: Info => Metadata Types & Components => Flow for Flows Info => Metadata Types & Components => FlowDefinition for Processes – sanket kumar Aug 13 '18 at 12:42
  • I checked the Flows, only two other flows. – Kamal Thakur Aug 13 '18 at 12:42
  • @sanketkumar I can see this under the FlowDefinition using the Workbench, but couldn't locate it in the frontend. – Kamal Thakur Aug 13 '18 at 12:47
  • 1
    can you once check the label for that particular flow.. may be some other label which is diffrent from developer name. – sanket kumar Aug 13 '18 at 13:09
2

After some investigation, what I found is that there is a bug in Salesforce due to which we're unable to see an active Process Builder Flow from Process Builder UI. This is what the Official Documentation said,

This happens when the user first creates a Process Builder Flow, which in the background is really just a special type of flow and should never be accessed or modified via Visual Workflow Designer. In short, accessing Process Builder flow via Visual workflow designer will cause such issue.

The article also provided a workaround: Unable to view active Process Builder Flow from Process Builder UI

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.