It's just bad code. The 52 must represent the number of characters the original author expected to need to skip after finding the string "API Requests, Last 24 Hours". That's a really bad idea because it will break if/when SF decide to change the format of that page at all.
If you're ever going to use a "magic number" like that, it's much better to give it a descriptive name. And if it comes from the length of a string, I like to use
.length() to show where I got the number from.
So, if I were to minorly rewrite that code, I'd write it as:
final Integer DISTANCE_FROM_LABEL_TO_VALUE = ('API Requests, Last 24 Hours'
+ '</span> </div> <div class="datalink"> <div class="num" id="usage_block_api_num_1"><span class="textOnly">').length();
final String SYSTEM_OVERVIEW_URL = '/setup/systemOverview.apexp';
PageReference pr = new PageReference(SYSTEM_OVERVIEW_URL);
String result = pr.getContent().toString();
Integer start_index = result.indexOf('API Requests, Last 24 Hours') + DISTANCE_FROM_LABEL_TO_VALUE;
Integer end_index = result.indexOf('<', start_index);
result = result.substring(start_index, end_index);
result = result.replaceAll(' ', ' ');
By showing where
DISTANCE_FROM_LABEL_TO_VALUE, it's really obvious that this is a bad idea as it will be brittle to changes in that page's format.
If you wanted to do it a bit better, then you could consider using the XML parser to try to parse the HTML and find the result via the DOM. Or, maybe look at using the API https://developer.salesforce.com/docs/atlas.en-us.api.meta/api/sforce_api_header_limitinfo.htm