0

I have the following problem: when I try to use the sfdx force:auth:web:login command, nothing happens. When i do it with sudo, a salesforce site opens and I put in my login & password, the site then says that 'we can't connect to the server localhost'. Meanwhile in the terminal i get the following error

Command failed with response. (secret-tool:3754): GLib-GObject-CRITICAL **: 20:52:24.080: g_object_unref: assertion 'G_IS_OBJECT (object)' failed secret-tool: Error spawning command line “dbus-launch --autolaunch=ce5e68462eef4ab6bb72802668bd136c --binary-syntax --close-stderr”: Child process exited with code 1 . Try this: Determine why this command failed to set an encryption key for user root: [/usr/bin/secret-tool store --label='salesforce.com' user local domain sfdx].

i tried googling it but with not much success. I'm using Manjaro Linux with KDE Plasma. I tried it on a freshly installed system (same) on a different machine, and got the same errors. I tried on a freshly installed system (Manjaro XFCE) on a different machine and it works.

So I would assume it has something to do with the KDE environment. I did install gnome-keyring because I saw that its absence can cause similar problems, but it didn't solve it for me.

Can someone help me out?

4
  • 1
    possible that the instance had not booted yet, have you re-triede since you got this error? is this repetitive? is this specific to 1 org you created? or reproduceable amongst all or most of them? if the problem persists, i would recommend contacting SF support
    – glls
    Commented Aug 8, 2018 at 21:25
  • It did work with this org before on a different system (linux mint). I tried logging into a different org, but with the same result
    – kuleje
    Commented Aug 9, 2018 at 5:53
  • Did you try what it suggests in the error message: Try this: Determine why this command failed to set an encryption key for user root: /usr/bin/secret-tool store --label='salesforce.com' user local domain sfdx Commented Aug 9, 2018 at 18:10
  • I tried to determine that but failed to do so. I ended up doing the same thing that I did on the other machine: reinstalling Manjaro with XFCE and then changing into KDE Plasma. It works
    – kuleje
    Commented Aug 10, 2018 at 8:16

2 Answers 2

1

I'm maintaining the sfdx-cli package on AUR for Arch, and have managed to reproduce this issue on a freshly installed system, albeit with GNOME instead of KDE.

In my case the issue is that Salesforce is bundling an old version of xdg-open, which calls executables that no longer exist on GNOME > 3.30. I am pretty certain that this also applies to KDE. You can try this workaround proposed by one of the users:

sudo cp /usr/bin/xdg-open /opt/sfdx-cli/node_modules/opn/vendor/xdg-open

That would replace the bundled version of xdg-open with the system xdg-open. Afterwards the auth should work (please don't use sudo with it).

1
  • This should be fixed with the latest versions of GNOME, Arch kernel, and SFDX CLI.
    – Zerkz
    Commented Feb 6, 2019 at 17:29
0

As far as I can tell the error is because you're running the process with sudo which in fact opens a new session and cannot therefore unlock the active user's keyring via dbus.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .