4

I have configured a salesforce instance to use Google for user Authentication via Open Id Connect. This is for users with full Salesforce licenses to login to Salesforce.

When I log in from a new network location (un-activated IP address) via the Google authentication, after successfully completing the google login I am routed to a page (at /_nc_external/identity/ic/ICNotNeeded) with the following content:

"Activation complete Your device has been automatically activated based upon network location. -- Continue -- (Button)."

On clicking Continue, my browser is redirected to the salesforce home page (/home/home.jsp), and then back to the login page, I assume because I am not logged in properly. Despite this, my IP address is added to the Activations list (Setup -> Security Controls -> Activations), and I can subsequently log in using the same Open Id Connect mechanism without a problem until I move to a new location.

I believe this is incorrect behaviour. The message on the page suggests to me that I have logged in successfully and clicking Continue will take me to the home page. But salesforce support deny there is any issue. (And then closed my case claiming that I was requesting developer support). They have pointed me towards some articles on white listing IP addresses.

My understanding is that I should not need to pass through activation for my login unless I am logging in from a new browser at a new IP address.

Has anyone successfully configured Salesforce with Open Id Connect to avoid this issue?

  • 1
    FYI, this has also happened to me when using two-factor authentication. – DuffJ Apr 7 '14 at 17:58
1

This was reported to Salesforce as a defect and was eventually accepted by support as an issue. It should be resolved in "Spring 14 or a later major release".

For anyone using OpenID Connect, it might also be useful to be aware that Internal Server Errors are currently experienced by a user when logging in using OpenID Connect from an un-activated browser or network location, and entering the activation code sent to them by Email or SMS. A subsequent login attempt is successful. Again the issue has been logged with Salesforce.

  • Thanks James, do you have a reference to the salesforce.com defect? – DuffJ Apr 7 '14 at 17:58
  • 1
    @DuffJ No, I'm afraid not. Support would not post this on Known Issues, I think the "activated automatically" message has been classified as a feature. It looks to me like this has not been resolved in Spring 14 either sadly, I last checked in a sandbox a week or two ago and the issue was still present. I also poked the PM on twitter but no news twitter.com/jamesmelv/status/446209146611056640. Your other comment makes sense, I can imagine that 2 factor auth might be tied into the same framework, did you log a ticket? – James Apr 7 '14 at 18:48
  • I raised a support case number 10418791 "Unable to log in to sandbox with two-factor authentication" - will let you know what they say. I've referenced this URL in the support case too. – DuffJ Apr 9 '14 at 14:23
  • 1
    salesforce support has closed off my issue as "awaiting bug fix". The bug fix reference is W-2009113 if anyone needs it. Expected delivery date is "summer 2014". – DuffJ Apr 22 '14 at 12:03
  • 1
    This was resolved in the Summer 14 release – James Sep 10 '14 at 6:19
0

I recently encountered this again and was able to circumvent it by using the SalesforceA app to log in and temporarily removing my 2-Factor authentication. Once I had done that I could log in from my desktop browser to restore the required security settings. This works by logging in from a different network, so your cellphone must either be on a different network or using Cellular service. Presumably you could also log in from your desktop if you used a different network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.