3

When I am trying to deploy (using ant) to my sandbox I am keep getting the many of the following errors: profiles/... - App Subscription User.profile -- Error: In field: application - no CustomApplication named standard__LightningInstrumentation found (line 78, column 30)

permissionsets/... -- Error: In field: application - no CustomApplication named standard__LightningInstrumentation found

How can I solve it?

5
  • 1
    you need to include standard__LightningInstrumentation in your package.xml
    – Himanshu
    Commented Aug 5, 2018 at 14:07
  • package.xml - Entity type: 'standard__LightningInstrumentation' is unknown
    – Ilan Hazan
    Commented Aug 5, 2018 at 15:07
  • You need to first retrieve this from your sandbox or if you don’t want to deploy this app, open your user profile.xml and remove reference
    – Himanshu
    Commented Aug 5, 2018 at 15:11
  • I'm having the same issue when deploying a profile unchanged from one Winter '18 org to another identical one - seems like a new bug in the metadata API. Commented Oct 17, 2018 at 5:48
  • I have just run into this issue after my sandboxes where refreshed from Prod and then the release of Winter 20 was released to Prod and the sandbox was updated as well, but I can see that the 'Lightning Usage App' is missing from my sandboxes. My API version is also on 46.
    – SaoBiz
    Commented Oct 14, 2019 at 22:16

3 Answers 3

1

I had the same issue and updated the API version to 45.0 in the package.xml file and it worked.

1
  • Hello Jason, Welcome to SFSE!! Please Post your question in detail. Commented Jan 7, 2019 at 6:43
1

When this happens you can, using the CLI, get the id of the object in question using sfdx force:data:soql:query -q "Select Id, MemberName From SourceMember Where MemberType = 'CustomApplication'" -t. Then use the Id from that query like below.

sfdx force:data:record:delete -s SourceMember -i 0MZ0x000001eqiJGAQ -t

0

I encountered an error similar to this when I was playing with my scratch org, pulled metadata to local, deleted metadata from the scratch org, pulled again, but my profile, for some odd reason, didn't sync with local. When I tried pushing to another scratch org, the error popped up.

In short, my profile sees remnant stuff that are non-existent, that's why the error was thrown.

If you're not trying to install a custom application named standard__LightningInstrumentation, then I suggest this fix:

  1. go into the profile
  2. search for the tag applicationVisibilities where the child tag application's value is standard__LightningInstrumentation
  3. delete it

It fixed my error. Hope it fixes yours.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .