0

I need to disable chatter feed to appear on home page and any record page. I have created VF page and used it in VF home page component but it is not working.

Please find below VF page code.

    <apex:page sidebar="false" showHeader="false" standardStyleSheets="false">
 <head>
 <script type="text/javascript">
    function hideChatterFeed(){
        var isFeedShown =
            document
                    .getElementById('hideFeedLink')
                    .style
                    .display == 'none' ? false:true;

        if(isFeedShown && chatter){
            if(sfdcPage.entityId){
                chatter.getFeed().toggle(
                    '{"subjectId":"' + sfdcPage.entityId + '","feedType":"ENTITY"}'
                );
            }
            else{
                chatter.getFeed().toggle(
                    '{"subjectId":"","feedType":"NEWS"}'
                );           
            }
        }
    }

    document.onreadystatechange = hideChatterFeed;
</script>

 </head>

</apex:page>

enter image description here

Please Help in this.

  • 1
    Why not just disable it entirely at that point? – Adrian Larson Aug 2 '18 at 12:06
  • since to Install CPQ package we need to enable Chatter in Org but we do not want users to see Chatter – Sharmila Aug 3 '18 at 5:09
0

As you already created a visualforce, try include on the style tags

 <style>
 .bPageTitle .metadata { display:none; }
 </style>

chatter component will remain internally although that tag will hide part where chatter is alocated on the Html.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.