0

I deployed some tabs from sandbox to production but they are not visible.

I checked profile settings. I see my tabs listed under Tab Settings > Custom Tab Settings. For all three profiles I have they are all set to "Default On".

Within Lightning App Builder, I go to Select Items. I see my tabs appear under "Selected Items".

What other settings do I need to check to make them visible?

  • Are those Tabs available in the app that you are trying to view? – Jayant Das Aug 2 '18 at 3:25
  • Yes they are. I can see them in the Custom Tabs page under Settings > Tabs. – ohseekay Aug 2 '18 at 3:27
  • That page will show you the tabs you have created. But for a tab to be visible, it needs to be added in an app (say Sales, or a custom app) along with the profile permissions. You may like to verify if the tab you are expecting is available for the app that you are viewing or not. – Jayant Das Aug 2 '18 at 3:29
  • Inside Lightning App Builder, I go to Select Items. Under "Selected Items" I see my custom tabs there. Is this what you are referring to? – ohseekay Aug 2 '18 at 3:32
  • Yes, so are you still not able to view those tabs in the app? – Jayant Das Aug 2 '18 at 3:32
0

With thanks to user Jayant Das, I have managed to solve my problem. Apparently this is a known issue - https://success.salesforce.com/issues_view?id=a1p3A0000001CsgQAE&title=custom-tab-not-visible-in-lightning-experience.

In my case, my tabs are not part of a managed package, so I deleted the tabs and remade them again. I made sure on step 3 of the process to check the "Append tab to users' existing personal customizations" option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.