I have created a public community group.  I added my users to the group as members.  To my surprise, unauthenticated guests with the link can see see the content of the group.  It is as if my guest user has rights to the public group.  Is there a way to fix this?  I only want my authenticated community users to see the contents of this public group.

1 Answer 1


Resolved guest users accessing a public Community group by removing the checkbox next to the "Give access to public API requests on Chatter" option in the Community/Administration/Preferences section.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .