0

I am ending up with the below error when I try to retrieve Process builder (Flow) using workbench. "Entity of type 'Flow' named 'My_Process' cannot be found"

My Package.xml is below:

<?xml version="1.0" encoding="UTF-8" ?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>My_Process</members>
        <name>Flow</name>
    </types>
    <types>
        <members>My_Process</members>
        <name>FlowDefinition</name>
    </types> 
    <version>43.0</version>
</Package>

Could someone please point me on what/where I am doing a mistake?

  • Only <types> <members>My_Process</members> <name>Flow</name> </types> will work. Otherwise try : <types> <members>*</members> <name>Flow</name> </types> – sfdc_sk Jul 31 '18 at 12:28
  • I did the same thing. I tried without flow definition too, it did not work. – Kanikala Jul 31 '18 at 12:34
  • When I tried using <types> <members>*</members> <name>Flow</name> </types> in my org , it worked for me. It gave me all flows present in my org. – sfdc_sk Jul 31 '18 at 13:18
  • You can try with this : try appending version number from your Flow Versions after your flow name as : <members>My_Process-1</members>. e.g here 1 is your version number. – sfdc_sk Jul 31 '18 at 13:28
  • 1
    @Kanikala - I will recommend that you provide the details as an answer, so that someone coming across this will be aware that this was resolved. – Jayant Das Jul 31 '18 at 15:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.