1

When I try to use the sfdx force:source:push call, I'm getting an error that denotes that No package.xml was found. I changed nothing because package.xml does exist in my project directory, tried to push again, and received an UNKNOWN_EXCEPTION: An unexpected error occurred. error in the cli. I changed nothing AGAIN, then ran the same commmand, and the code pushed successfully. Has anyone else experienced what seems to be a bug with the latest version of the CLI?

CLI Version: sfdx-cli/6.26.0

salesforcedx version: salesforcedx 43.9.0

1

We had similar issue for a long time.

Firstly it started with randomly popping no package.xml found error + unknown exceptions time to time.

What helped with no package.xml -> creating classes, lightning comopnents and triggers etc always with force:apex:class:create or force:lightning:component:create or relevant. There is small diffrence in meta-xml definition which should not make a diffrence at all but it magically helped.

NExt we had problem with Unknown Exceptions. And a lot of them (record was 16 tries before succesfull push)

First of all: it even doesnt start to deploy stuff when you get this exception -> deploy status on scratch org will be empty. Secondly: After some time I observed that amount of UNKNOWN EXCEPTION was rising during business hours in our region. Next clue was that our server instance had some PERFORMANCE DEGRADATION periods around when our issues occured (but not exactly when we tried to push something)

After that my assumption was that Salesforce servers are just rejecting our push request when payload was to high.

We contacted Salesforce support desciribing our issue. After two weeks of investigation and without any direct answer everything just started to work like a charm. No unknown exception no package.xml just boom we're back in game. Support didn't respond till that moment so we just closed the case.

My advice here is:

Raise a case to a support with as specific description as you can provide and escalate as soon as you think it would be wise. Unfortunately I think that "first line of defence" of support wont help much.

I'm sorry that's not direct answer but I think it's easier to read than a comment.

  • In response to the first suggestion (Using the force command for class/component creation), I noticed this made a difference originally as well. This bug occurred after pulling a co-worker's changes from git. It would be VERY annoying and tedious to use force...create after every git pull even if I didn't create the class myself. In response to your Unknown Exception recommendation, grrr. I'll raise a case when this becomes worse and let you know if they reveal any specifics. – Kai Tribble Jul 27 '18 at 20:03
  • Well most of us have vs code which have extension that have shortcuts to creating classes so it was easier to mainatain this stuff in project – user1974566 Jul 27 '18 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.