Unable to find any solution on web related to this issue?

I am trying to run Hello World(Quick start - Advance section of Canvas guide) application. Hello World application is running on my local but when click on application in Canvas App Viewer getting following error-

Oops, there was an error rendering Force.com Canvas application [Hello World]. You don't have permissions to view application with namespace [ingcanvas] and API name [Hello_World].

Unable to find the permission issue?

enter image description here enter image description here enter image description here

2 Answers 2


I encountered this error in a Canvas app I recently developed, the sub-text below the error for me gave me the direction i needed to resolve it....

enter image description here

The canvas app requires you to set permitted users in order to be rendered. Please configure the app polices to "Admin-approved users" instead of "All Users" and grant users access by profile or permission set

Assuming this is the subtext below your error messages, this is what I did...

  1. Click the "Click to configure" link and edit the “Admin approved users are pre-authorised” option and save. enter image description here.

  2. Finally edit your Profile and enable the Connected App Access (and Tab if needed) enter image description here

Hope this helps!

  • 1
    That's exactly what I needed. System Administrator was missing the Connected App Access for the new canvas app. Thank you.
    – tggagne
    Jan 16, 2014 at 17:33

I hit a similar issue to this in a scratch org, but all users were allowed to self-authorize and the admin profile had access, so it was neither of those. In the end what got it going. The only message was around my login not being valid, so I logged out, used sfdx force:user:password:generate (yes this is already out of date but I haven't looked up the new command) and then logged in with the password via test.salesforce.com

After doing that the canvas preview tool worked as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .