0

I had a SFDX project which I converted to follow the "sfdx-falcon-template" structure. I also created a packaging org that would be used as a base for my managed package.

Next I created a namespace and a managed package and updated my "sfdx-project.json" file according to sfdx-falcon-template:

{
  "packageDirectories": [
    { "path": "sfdx-source/<my-namespace>", "default": true },
    { "path": "sfdx-source/unpackaged"},
    { "path": "sfdx-source/untracked"}
  ],
  "namespace": "<my-namespace>",
  "sfdcLoginUrl": "https://login.salesforce.com",
  "sourceApiVersion": "42.0"
}

I use <my-namespace> as an example here, I don't want to expose the real name.

Then I issued the ./dev-tools/rebuild-scratch-org command in command line which basically created a new scratch org and deployed all the metadata and code there. The command ran successfully and I ran all the tests to verify nothing got broken. Everything was fine so far.

But when I tried to deploy my application to my packagking org, it failed:

=== Result
Status:  Failed
jobid:  0Af1t000002pL79CAE
Completed:  2018-07-23T14:25:44.000Z
Component errors:  438
Components deployed:  91
Components total:  529
Tests errors:  0
Tests completed:  0
Tests total:  0
Check only: false

This is weird and seems that something wrong with a namespace. Does anybody know how to fix this and deploy my app into the package org eventually?

0

I found what issue was. I have 2 custom objects with <startsWith>Vowel</startsWith> in their metadata definition. And in a long log of errors I found this line:

Cannot specify a startsWith attribute for this language

When I removed <startsWith>Vowel</startsWith> from objects' metadata definition, deployment finished successfully.

P.S. This is odd that this object setting didn't allow deploying mdapi to packaging org with a namespace, but it deployed to a scratch org smoothly. That's ridiculous, I'm confused.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.