2

I am doing this trailhead (https://trailhead.salesforce.com/modules/api_basics/units/api_basics_soap) and done everything whatevet mention in this and i got success message that account is created but when i click on the check & challenge button it's showing error message

Challenge not yet complete... here's what's wrong: It doesn't appear that you have logged in using SoapUI.

i have changed the url login into https://na30.force.com/services/Soap/c/43.0/00D28000000W51I

enter image description here

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
 xmlns:urn="urn:enterprise.soap.sforce.com" 
  xmlns:urn1="urn:sobject.enterprise.soap.sforce.com">
   <soapenv:Header>
      <urn:SessionHeader>
         <urn:sessionId>

       00D29000000W51I!AQ0AQITKnUtm959kozyLqpu.c8Kki7cVuT.
        E2f7dgKHpalQss_MAM2cUiFtcLR516JTFauDnM2HX6AWHUkKOGj3jttYah.C9
       </urn:sessionId>
      </urn:SessionHeader>
    </soapenv:Header>
   <soapenv:Body>
      <urn:create>

             <urn:sObjects xsi:type="urn1:Account" 
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Name>Bluebeards Grog House</Name>
               <description>It is better than Blackbeards.</description>
        </urn:sObjects>
      </urn:create>
    </soapenv:Body>

---output window---

       <soapenv:Envelope 
        xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
         xmlns="urn:enterprise.soap.sforce.com">
     <soapenv:Header>
          <LimitInfoHeader>
           <limitInfo>
               <current>5</current>
                <limit>5000</limit>
                <type>API REQUESTS</type>
             </limitInfo>
       </LimitInfoHeader>
    </soapenv:Header>
   <soapenv:Body>
       <createResponse>
          <result>
            <id>0010I00001ujGYsQAM</id>
            <success>true</success>
         </result>
      </createResponse>
   </soapenv:Body>
 </soapenv:Envelope>

enter image description here

  • Have you created the Account into the Right Playground ORG? – Amit Singh Jul 23 '18 at 7:33
  • yes i have created – cloudZigZag Jul 23 '18 at 7:42
  • You have to call the login method using SoapUI, as specified in the directions on the trailhead. It's not sufficient to use any other existing Session Id for this purpose. – sfdcfox Jul 23 '18 at 8:09
  • after using login method i got sessionid . without login how can i get sessionid. i am wondering account is created with name of Bluebeards Grog House and description It is better than Blackbeards. – cloudZigZag Jul 23 '18 at 9:06
1

Trailhead will be looking for a LoginHistory record in the verification org that indicates SoapUI was used to establish a session.

I revisited this challenge to see what was going on. I initially used a really old dev org and ran into the same problem you did. The verification kept complaining that:

It doesn't appear that you have logged in using SoapUI.

Which was odd, as I'd explicitly performed the login and create calls via Soap UI.

In my case I found the problem was with the org itself. Trailhead didn't like that it had a namespace assigned for packaging.

Instead I switched to Trailhead Playground org and repeated the login and create calls. Here is what the LoginHistory looked like when the verification passed:

LoginType: Other Apex API
LoginUrl: login.salesforce.com
TlsProtocol: TLS 1.2
Browser: Unknown
Platform: 
Status: Success
Application: N/A
ClientVersion: N/A
ApiType: SOAP Partner
ApiVersion: 36.0

Try a SOQL query like the following to check. You will also see the Trailhead application login this way to perform the verification.

Select Id,UserId,LoginTime,LoginType,SourceIp,LoginUrl,LoginGeoId,TlsProtocol,Browser,Platform,Status,Application,ClientVersion,ApiType,ApiVersion from LoginHistory order by LoginTime desc`

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.