6

I'm studying up for my sharing and visibility exam right now, and am looking at Apex Sharing reasons.

According to the documentation, to create an Apex sharing reason:

  1. From the management settings for the custom object, click New in the Apex Sharing Reasons related list.
  2. Enter a label for the Apex sharing reason. The label displays in the Reason column when viewing the sharing for a record in the user interface. The label is also enabled for translation through the Translation Workbench.
  3. Enter a name for the Apex sharing reason. The name is used when referencing the reason in the API and Apex. This name can contain only underscores and alphanumeric characters, and must be unique in your org. It must begin with a letter, not include spaces, not end with an underscore, and not contain two consecutive underscores.
  4. Click Save.

My issue is, when I go to my custom object, I can't see the "Apex Sharing Reasons" related list. I've ensured that the object is set to Private in the OWD:

enter image description here

I read in a post from 2014 that someone had to go to SF support to get the Apex Sharing Reasons feature activated, but that SF had told them to go to the developer forums to get it "activated internally". This seems odd to me, and the post is pretty old.

1
  • 1
    wish we could do this in LEX...
    – krigi
    Sep 30, 2019 at 16:06

2 Answers 2

15

As per the Salesforce Help Documentation Apex Sharing Reasons are only available in Salesforce Classic and I presume based on the screenshot shared above, you are using Lightning Experience.

Hence you will need to switch back to Classic, enable Apex Sharing Reasons as per the mentioned steps and then proceed.

1
  • 1
    No worries. Glad I could be of help!
    – Jigar Shah
    Jul 20, 2018 at 8:56
0

Make sure your custom object OWD setting is Private.

Moreover, you need these 2 permissions:

To create Apex sharing reasons: Author Apex To view Apex sharing reasons: View Setup and Configuration

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .