0

I have a lightning component that contains a lightning:inputRichText field working in a sandbox. When I deployed the component to another sandbox using ANT, I'm getting an error about quillLib.js as shown below when I try to type in the form.

quillLib.js error occurring on lightning:inputRichText in new sandbox

Both sandboxes are on API v43.0.

Has anyone seen this error or know why it's happening? Will raise a case with Salesforce also, as it seems to be an internal error.

3
  • Did you try in another browser? lightning:inputRichText uses quill.js and it could be an issue from that library. Jul 20, 2018 at 8:28
  • Yeah, I tried in both Chrome and Safari and the same issue still occurs. Jul 20, 2018 at 8:29
  • 1
    Update: Raised a case with Salesforce and they confirmed they were able to deploy the component to a new org without any issues. Looks like a problem with our sandboxes and has been escalated to T3 support. To be continued! Jul 20, 2018 at 17:36

1 Answer 1

0

Managed to find an answer for this one through some experimentation - it seems that my force:recordData component (which was trying to populate a custom rich text field on my chat object) couldn't access the custom field in any sandboxes past the one where the object and field were originally created.

Even though I had layoutType specified as FULL, I had to specifically include the new "Body__c" field in the fields parameter. This is because I forgot to deploy the layout for the new object that included this field, so the only fields available when I specified "FULL" were the ID and any other required fields.

<force:recordData aura:id="chatRecordCreator" 
                      layoutType="FULL"
                      targetRecord="{!v.newChat}"
                      targetFields="{!v.simpleNewChat}"
                      targetError="{!v.newChatError}" 
                      fields="Body__c" />
......

<lightning:inputRichText value="{!v.simpleNewChat.Body__c}" />

Seems like there was some internal access issue on the field which was causing the null pointer in the quillLib.js class. Once I specifically provided access to the field on the force:recordData component, it worked.

Some more information on the Lightning Data Service from the Summer '17 highlights here.

More info about the difference between layoutType and fields attributes here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .