I am getting the following error when I am trying to log into Data Loader:

Failed to send request to

I checked that I am providing the correct Username, and the correct Password (in the form of password + Security token).

So, what else may be wrong here?

enter image description here

After changing the Salesforce Login URL here is what I am getting:

enter image description here

3 Answers 3


The Password should be a combination of Password + Security Token if you do not have IP Whitelisting done.

Also, if you are connecting to a Production / Developer instance, the url https://login.salesforce.com is valid.

If it is a Sandbox that you are trying to connect to the then the url should be https://test.salesforce.com

  • 1
    Lol, I tried the same solution and it did not help. But it worked when I tried it after your answer. Thank you.
    – iloveseven
    Jul 20, 2018 at 8:34
  • I am glad I could help.
    – Jigar Shah
    Jul 20, 2018 at 8:39

Try changing data loader settings once as below: Open Data Loader -> At the top click on settings -> Set the server host to https://login.salesforce.com -> ok Then try logging in.


For me it was the VPN. Salesforce suggests in the article to update proxy settings in Data Loader > Settings > Proxy Host / Port.

  1. Check if your network is using a proxy - Getting the error message, "Failed to send request to https://www.salesforce.com/services/Soap/u/31.0" typically indicates that you're going through a proxy server resulting in your login attempt from the Data Loader not making it from your local machine to Salesforce servers. If your network is utilizing a VPN, you'll need to include or set your proxy information in the Data Loader settings. We recommend contacting your IT department to get the following pieces of information:
  • Proxy host
  • Proxy port
  • Proxy username
  • Proxy password settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .