4

I am using ANT to deploy a custom package which includes custom code and managed packages. I have deployed the custom package to multiple environments without any issues but I am now facing the following error when attempting to deploy to higher environments.

Property 'activateRSS' not valid in version 28.0

I am the owner of the managed packages and have done a search to see if I can find where the activateRSS property is being referenced and it is not in any file of either managed packages. I also have access to the custom source code, and a search for activateRSS also returned 0 results.

Does anybody know why I may be receiving such error and how I should go about resolving it?

Update (July 19th)

New Known Issue : Metadata deploy of InstalledPackage in v42 and below failing when activateRSS is not specified.

  • I get this too. Is there a fix yet? this is stopping me deploy to our customers staging org – MarcusMaximi Jul 13 '18 at 21:58
  • @MarcusMaximi have you wrote your own ANT tasks that may be performing the package retrieval at time of package installation? Or how are you retrieving the package to be installed/upgraded? – TSmith Jul 17 '18 at 14:05
2

There is the Known Issue - Summer'18 - unrecognized field activateRSS on InstalledPackage while using MetaData API, which indicates it should have been resolved in SUMMER '18 PATCH 10.1 and is currently deployed to all pods.

It does provide some clues as to where the activateRSS element appears under InstalledPackage.

InstalledPackage.activateRss is only valid from API versions 43.0 and later. So it could certainly cause problems with an older 28.0 version of the MetadataAPI via the ANT deploy tool.

I'd double check any metadata you have for InstalledPackage elements.

| improve this answer | |
  • This is still failing for us. Any news about it? – jvrdelafuente Jul 12 '18 at 14:53
  • @jvrdelafuente Is your failure directly related to the existing known issue, or is it a variation of an activateRSS error? – Daniel Ballinger Jul 12 '18 at 20:10
  • 1
    Salesforce are looking into this issue through a support case for me. They have mentioned that the known issue indicated in @DanielBallinger answer may have resurfaced. – TSmith Jul 16 '18 at 9:02
  • I think that is the same issue. installedPackages/projectName.installedPackage -- Error: Property 'activateRSS' not valid in version 36.0. It looked like it was fixed on Friday but it broke again during the weekend. – jvrdelafuente Jul 16 '18 at 9:53
  • There was a Salesforce patch rolled back over very recently. That might explain why it has regressed. – Daniel Ballinger Jul 16 '18 at 10:03
0

Using <activateRSS>true</activateRSS> solve the issue. Though <activateRSS xsi:nil="true"/> this was giving error.

So Ideal package.xml would look like this

<?xml version="1.0" encoding="UTF-8"?>
<InstalledPackage xmlns="http://soap.sforce.com/2006/04/metadata" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <activateRSS>true</activateRSS>
    <versionNumber>xyz</versionNumber>
</InstalledPackage>
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.