9

I'm working on a project for German customer and I'm using Salesforce DX to work with scratch-orgs. There's a nice script to configure everything and it was working fine till Summer'18.

Since Summer'18 I'm (and entire team is) getting most of the time following error:

Dieser Benutzer ist Portaladministrator und muss ein Profil mit der Berechtigung zur Bearbeitung von Self-Service-Benutzern besitzen.: __MISSING_LABEL_FOR_common.udd.impl.UddInfoImpl@43dfee08.

which in English would be:

This user is a portal administrator and must have a profile with the "Edit Self-Service Users" permission

Here is beginning of our script:

1. sfdx force:org:create -f ./config/project-scratch-def.json -a name -s
2. sfdx force:data:record:update -s User -w "LastName=User" -v "LanguageLocaleKey=en_US CountryCode=DE" // used to change the User's language so that we can work in English

We get this error on step 2 when trying to change the User's language. Most of the times means that after few attempts finally we get scratch org that doesn't fail at this step.

The same error appears when we try to update the User via UI. enter image description here We don't have any Customer Portal, nor the Community that's why it's so strange.

Here is our project-scratch-def.json:

{
    "orgName": "SomeName",
    "edition": "Enterprise",
    "orgPreferences" : {
        "enabled": ["S1DesktopEnabled", "ChatterEnabled", "EnhancedEmailEnabled"]
    },
    "features": ["LightningSalesConsole", "StateAndCountryPicklist"],
    "language": "de" // needed because without it we can't push objects and fields
}

I checked it with other Dev Hub and get the same error on User's update

EDIT 19/09/2019

On another project got the same error when trying to mark scratch org as Marketing User with command:

sfdx force:data:record:update -s User -w "Email='some@email.com'" -v "UserPermissionsMarketingUser=true"

The error being:

ERROR running force:data:record:update: This user is a portal administrator and must have a profile with the "Manage Customer Users" permission.: __MISSING_LABEL_FOR_common.udd.impl.UddInfoImpl@5f151d7d

Our workaround is again to keep trying until we get a proper scratch org.

  • 2
    I have the same issue but randomly. Some Scratch Orgs are ok and some other are not. I start talking about this here but haven't got an answer yet: success.salesforce.com/_ui/core/chatter/groups/… – Fabien Taillon Jul 11 '18 at 15:18
  • same here. I submitted support case for this over 1 week ago but no success so far. Thanks for the link, that's exactly same issue – neff Jul 11 '18 at 15:27
  • As a german ISV we're sitting in the same boat. Is the behaviour the same if you DO NOT update the user with '"LanguageLocaleKey=en_US CountryCode=DE" ' BUT add Country = 'US', language="en_US" to the project-scratch-def.json That's how we tackle language changes for a german dev hub org. i do not know if it has any impact – Christian Szandor Knapp Jul 11 '18 at 16:56
  • Christian, this would solve the language problem (since we don't need to update User then, when trying to update it's still there), however our metadata (objects, fields) is then incompatible with scratch org and we can't push it. That's the example: force-app\main\default\objects\Quote__c\Quote__c.object-meta.xml Cannot specify a gender for a gender neutral language. We would need to rewrite the metadata to English? Atm we are creating scratch orgs until we get a proper one – neff Jul 12 '18 at 6:44
  • 4
    This has been determined to be bug. Expect a patch in the next couple of weeks. Thanks for surfacing this issue! – Dave Carroll Jul 13 '18 at 22:40
1

As mentioned by Dave Carroll in the question's comments, this appears to be a bug. A patch should be coming soon.

In the mean time, the workaround is to use "Developer" as the scratch org edition.

| improve this answer | |
  • Vivek, this still seems to be open. I just ran into this when using the CircleCI part of your Falcon template. It defines the test scratch org as an Enterprise edition. – Robert Sösemann Oct 27 '18 at 19:43
  • 1
    @RobertSösemann - I'll reach out to the product team to see if I can get a status update. – Vivek M. Chawla Oct 27 '18 at 23:16
0

Found this in the dev forums: https://developer.salesforce.com/forums/?id=9060G0000005qljQAA

This worked for me when I got this error updating in a full sandbox.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.