0

I have Created an Custom Object "Text Subscriptions" And also created a Custom Fields as Account which has Master-details Field type. I have Created some More Custom fields: Text Plan, SMS Number, status, Renewal Date. I am able to add data into these custom Objects but when it is displayed as a section in Account layout it only shows the Standard Field of My Custom Object: Text Subscription Name(Standard Object). Please check the below image

enter image description here

Now My concern is, how can i display the rest of Custom fields along with Text Subscription Name in different columns. Let me make myself clear that this is a sandbox.

Image of Account Page Layout: enter image description here

Thanks in advance.

  • Edit the Account layout and goto Text Subscription related list. Click on setting icon at the right corner of the related list and add the field which you need – wAitIng dOg Jul 6 '18 at 7:15
  • @wAitIngdOg I have already added the required custom fields in related List but still nothing is happening... – Rahul Malhotra Jul 6 '18 at 7:20
  • Check whether you have the permissions for those fields. Go to that field setup and check Visibility. Did you deploy these fields in your sandbox or created it manually? – wAitIng dOg Jul 6 '18 at 7:22
  • I created all the fields manually..and checked the visibilty – Rahul Malhotra Jul 6 '18 at 7:30
  • Can you post the Screenshot of the related list pagelayout where you have added the fields – wAitIng dOg Jul 6 '18 at 7:32
1

There are 2 possible reasons,

  1. Fields not added in the layout

    Edit the Account layout and goto Text Subscription related list. Click on setting icon at the right corner of the related list and add the field which you need

  2. Field level permission not given

    Goto Field setup , check the visibility

  • Thanks wAitIng dOg for your Support, but i managed to get it visible somehow. I opened an Individual account and then Click on "Edit Layout". After this i added the required fields into related List and it worked. I don't know why it was not working on the other way. Anyways Thanks!! – Rahul Malhotra Jul 6 '18 at 10:37
  • You might have multiple Account Page layouts. Check whether you are editing the right layout or not. – wAitIng dOg Jul 6 '18 at 12:23
0

You have to add the required fields in the related list layout.

Go to required page layout of 'Account' object, click on edit, search of related list section, click on wrench icon for 'Text Subscriptions', add the required fields in the layout.

Refer the screenshot below.

enter image description here

Let me know if this doenst work.

  • I have already done these steps but still no change appear. I have given the permissions also. Is there anything else i might be missing?? – Rahul Malhotra Jul 6 '18 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.