1

So, reading documentation regarding locker-service I get that the only way of disable it, is downgrading the api version of each component to 39 or less. Also, documentation says that there is no hierarchy between components regarding locker-service. That works fine in one org that I have, but in another org, it's not working as expected. Could be some other reason for that? Some extra configuration that i'm missing?

Use case:
I have two scripts that are loading form a static resource (with public cache) in one component, I downgrade that component to version 39 so those scripts are not loaded with data-locker-src, in a sandbox org works fine, but in another sandbox org this does not work, it still load the scripts with data-locker-src.

I test the site in an Internet Explorer 11 and as documentation says, locker-service is deactivated (tested with the problematic org)

1

Locker should behave exactly the same. How are you loading the scripts? How are you loading setting the API version?

Make sure the browser has cleared its caches (browsers love to hold on content nowadays) and the API version on the component appears to stick sometimes.

Maybe try this:

  • Close all resources in Dev Console, close Console itself, then reopen it, reopen the component, and check that the API version is set properly on it.
  • Clear all browser caches and reload the page where the component is loaded. There are browser plugins that can simplify the task of clearing caches.
  • I actually had to try other workaround, so I can't say that this fix my issue, but this should work. I did try to delete cache on some levels, and is true that cache with browsers and salesforce is general is a bit weird. Best solution for me was actually not rely on workarounds for locker service, but when I asked the question it was the only choice that I had. I can't assure that the orgs where configured equally, so maybe The problematic org had special security settings. Thanks for the response. – djpeluca Jul 5 '18 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.