3

I run into a issue when using lightning:recordEditForm to together Account Name info in an org where Salesforce Person Account is turned on. I was trying to bind to a business account and edit the account Following is the code:

 <aura:component implements="force:appHostable">
    <!--recordId is a business account Id-->
    <!--recordTypeId is the business account record type Id-->
    <lightning:recordEditForm objectApiName = "Account" recordId="0013C0000094ah2" recordTypeId="0123C000000Li7hQAC">
            <lightning:inputField fieldName="Name"/>
    </lightning:recordEditForm>
</aura:component>   

Here is what I see on the UI enter image description here

My expected result is that the UI should only show Account Name field instead of three fields like salutation, firstname, lastname. since that was a business account Id I bind, not salesforce person account.

This seems like a bug on force:recordEditForm. Does any one run into same issue, and kindly provide some guidance on walk around? OR any salesforce docs about this issue (I didn't find any useful references myself).

Your help is apperciated!

3
  • Seems like you have found a bug in the implementation. Though the documentation says that it supports Name vs. Compound Name, but looks like in case of person accounts, it always displays these fields. I was able to replicate this and couldn't find any workaround for this so far. You may like to open a case to Salesforce, if that helps.
    – Jayant Das
    Jun 29, 2018 at 22:37
  • posted an idea on idea exchange vote if you have the same issue: success.salesforce.com/ideaView?id=0873A000000TwnZQAS
    – bluecat
    Jun 29, 2018 at 23:29
  • Will vote up, but I would say if you have a support channel, open a case for this as it’s more an issue rather than an idea.
    – Jayant Das
    Jun 30, 2018 at 0:00

1 Answer 1

0

if you fill in the recordtypeid attribute with a business account recordtype, this should work.

1
  • Tried with the record type Id filled with business account record type, still same ui got displayed :(
    – bluecat
    Jul 10, 2018 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .