0

I have created the permission set to disable all objects (Read only access) but my requirement is to provide edit access for 2 fields in permission set. So i have checked edit access with read access for those fields in field permission and also i have Checked Read and create in Object permission but still i am unable to edit those fields. It is still showing fields in read only mode. Please let me know solutions for these to make those fields editable in permission set.

Thanks, Anish

  • do you have Edit permission at object level? – Santanu Boral Jun 27 '18 at 17:31
  • No . I don't have edit access at object level. If i give edit access at object level it is enabling edit access for all fields. – Anish Jun 27 '18 at 17:40
  • You cannot use a permission set to remove access to a field or object only grant additional permissions, so that is why what you tried would not have worked. – Dave Humm Jun 27 '18 at 19:50
5

If you don't have Edit access at Object level then, only providing Edit access at FLS will not enable record for Edit.

So, provide Edit access at Object at profile/permission set and then only provide FLS to those fields. Also, remove edit access from the rest of other fields.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.