2

I tried to deploy letterheads metadata file to a development sandbox using ant build sf deploy. The deploy task fails with an error message stating that no Document named Letterhead_Logos/Application_Logo.jpg not found. The irony is that my letter does not use a logo at all.

E.g my letter is Application_Logo.letter and it is complaining for a logo not found. I simply copied the letter heads metadata files from eclipse to a folder and i am using ant to deploy to the same org. I use eclipse to retrieve my files from an org and i am using ant to deploy to the same org with the same meta data and still it is failing . What am i missing? Buyan

  • The error is due to package.xml specifying the application_logo.jpg but this does not exist to deploy . – Mohith Shrivastava Dec 13 '13 at 19:58
  • @MohithKumar My package.xml does not have any reference to application_logo. All i have is a folder called letterHeads with meta data for each letter head. what am i missing on the package.xml or folder which salesforce complains? – buyan kumar Dec 13 '13 at 22:18
  • @MohithKumar here is my package xml <types> <members>*</members> <name>Letterhead</name> </types> – buyan kumar Dec 13 '13 at 22:26
2

Chances are that Salesforce saved that document for you. This also happens when you create custom app icons and custom tab icons (both save the image into documents).

If you add the following to your package.xml you should be good to go

<types>
    <members>Letterhead_Logos</members>
    <members>Letterhead_Logos/Application_Logo.jpg</members>
    <name>Document</name>
</types>
  • Thx for your help. Where can i download this logo.jpg file from salesforce? If i add the logos to the package.xml file, it complains that the file is missing. Do you know where salesforce stores the logos and how do i retrieve them? – buyan kumar Dec 16 '13 at 15:08
  • Any document can be found in the documents tab in the particular folder, in this case letterhead logos. Did you do a retrieve to pull down the logo? The error message is making it sound like you updated the package.xml with the new file and tried to deploy without actually retrieving it. Although if you're saying you'd tried to retrieve the file and salesforce is saying it doesn't exist, that's something more distressing. – Ralph Callaway Dec 16 '13 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.