I just downloaded the Salesforce1 Android app. I signed in just fine to my dev account but about 20 seconds after signing in I got a message saying my admin had revoked my access token and was kicked out to the login screen. This is really weird because I am the admin and I certainly didn't revoke my own access token (or anyone's for that matter), especially not in that narrow window.

I tried logging in again but it just clears my username and password and says "Please enter your User Name" in red as if that was the issue. No matter how many times I try to log in this is the only error message it gives me. I tried clearing cookies and reloading from the menu in the top right but that hasn't done anything.

  • 1
    What happens if you log in from Chrome on Android? It should redirect you to the /one/one.app URL. Double check in Connected Apps to see if the new mobile app components got installed and are granting you permission. Dec 13, 2013 at 19:03
  • Thanks @ThomasTaylor, checking Connected Apps helped me figure it out. See my answer below. Dec 13, 2013 at 21:33

3 Answers 3


OK, thanks to @ThomasTaylor, I found out that the answer turned out to be Connected Apps settings under Setup/Administration Setup/Manage Apps/Connected Apps. I'd never been to this page to my knowledge and I'm the only one who uses this SFDC account, so I'm not sure if this was a default setting or if was changed somehow.

The Permitted Users for Salesforce1/Chatter for Android was set to "Admin approved users are pre-authorized" while every other app was set to "All users may self-authorize". I changed to it to "All users may self-authorize" and was able to log in again.

I'm not sure how the permitted users settings was changed for this. It's odd that I was able to log in at all, albeit briefly. It makes me think that something programatically changed it on me.

The errors that Salesforce1 gives are not that good. If it had told me I didn't have permission when I tried to log in, that would have been more helpful.


On my Samsung NOte 3 I downloaded the ap and had similar difficulty.

By going to the sign on screen, I then selected the settings button at the bottom (on the phone, not the screen) and I clicked on "Change Server". I then entered the web address of Salesforce that we use, and it was fine.

THis is a one time step.


You were able to login briefly for the first time because probably the timeout value must have been set for some 15 mins in connected app section.

  • That might help in a different situation, but the poster has said his solution to his problem was to change the app's Permitted Users setting to "All users may self-authorize"
    – martin
    Oct 20, 2016 at 7:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .