1

I try to use the RedirectTo function from Marketing Cloud Ampscript in a email. My code looks as follows:

%%[
VAR @hash, @url, @contact_DE, @subscriberkey, @finalurl

SET @contact_DE = "Contact_Salesforce"
set @subscriberkey = [_subscriberkey]
set @hash = Lookup(@contact_DE, "Self_Service_Token__c", "Id", @subscriberkey)
SET @url = "https://www.website.com/CommunitiesChangePassword?ct="
SET @finalurl=CONCAT(@url,@hash)
]%%

<a href="%%=RedirectTo(@finalurl)=%%">link</a>

When i go to Send Preview it shows the correct link: https://www.website.com/CommunitiesChangePassword?ct=49vdmdk39

When i do a Test Send it shows the correct link as well.

But when i use this email in a journey the link is showing up completely different: https://click.mailing.website.com/?qs=c0bcb76296ae07f2e52070b73ba8a822f57cf2b95a314378b1bc54f846763af108faffc9c42e3d8822a059eed521a5d3197859b0fb68c0ba

Does anyone know what the problem is?

1

When you send an email from marketing cloud with click tracking enabled it will wrap your link in a link that looks like that. That is how the system tracks the clicks.

What should happen is when you click that link it will redirect to the link that you set via @finalurl

  • Thank you for your help! I turned of email tracking and it works. – wfrankhuizen Jun 26 '18 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.