1

As I have added every code for push notification as per the document from mobile sdk for android in my app. In my developer org i got the message notification sent successfully but i didn't received any notification message on my android device. So please guide me where i am going wrong. Any help will be appreciated. Thanks.

I am working on android mobile sdk. And i was working on push notification. This push notification will send notification from Salesforce development edition to my android device. According to Salesforce Mobile guide https://developer.salesforce.com/docs/atlas.en-us.mobile_sdk.meta/mobile_sdk/push_using_android.htm I have implemented all methods of push notification in my android source code. But I am not getting any push notification. There is no error in logcat. enter image description here

closed as unclear what you're asking by David Reed, glls, Gortonington, battery.cord, Raul Jun 20 '18 at 16:27

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Salesforce has different SDKs for different products. Which SDK are you using? Do you have LogCat output from the device captured while initializing the SDK and while the message should have been received? – Bill Mote Jun 20 '18 at 12:27
  • Its for android mobile sdk. Working on android studio. And I am not getting any response in my android studio Log Cat regarding to push notification from salesforce. I am using FCM legacy server key in salesforce for server key. As GCM has been deprecated. – Azhar osws Jun 21 '18 at 7:16
  • @BillMote I appreciate your efforts to keep questions open which you feel deserving, but please moderate your tone. As it stands, this post A) does not ask a question, B) does not clarify expected behavior, C) does not clarify what the OP is doing to achieve this output, and D) does not specify what "going wrong" means in this case. Given these lacks, I find it entirely appropriate the question was closed. It has nothing to do with the fact this question asks about SDK. – Adrian Larson Jun 21 '18 at 19:13
  • @BillMote If you can clean this post up to more clearly indicate what is being asked, it will automatically enter the Reopen queue. – Adrian Larson Jun 21 '18 at 19:15
  • Please see salesforce-marketingcloud.github.io/JB4A-SDK-Android/… for troubleshooting steps. And edit your question with Log output, etc. – Bill Mote Jun 23 '18 at 11:48