0

I have a problem, when I try to use Salesforce CLI tools for DX, it works for when I type and execute them in standard windows "cmd" program but doesn't work when I run them from Git Bash terminal.

Looks like the problem is that it is installed into "Program Files" folder which contains spaces and git internal linux bash file and path system doesn't work well with spaces in the path.

I have asked a similar question on SuperUser stackoverflow forum, but nobody helped me to resolve this issue.

I tried to install CLI into separate folder without spaces, but it fails again, now because the folder itself has a space in it: "Salesforce CLI".

enter image description here

I am not sure if renaming the folder would help or quoting the folder path in the path system variable

1

So, after renaming the folder into "C:\Tools\SalesforceCLI\bin" and modifying a path environment variable I was able to resolve the issue.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.