4

I deployed a new RecordType to an Opportunity (where other RecordTypes/Sales Processes already existed). I notice that my RecordType, when selected on a new Opportunity, returns bad data for my Stage Picklist (it shows stages that are not any one Sales Process). When I try to edit the RecordType's Sales Process for testing, I get the following error on the RecordType Label:

Duplicate Values Not Allowed

I definitely don't have any other Record Types of the same name, and I tried changing the Label to a variety of random words just to verify that nothing worked. I also tried to make a new RecordType based on the previous failing one (as well as trying RecordTypes already existing in the system), and it had the same issues after the initial save. It seems like editing anything except the Sales Process meant the RecordType saved fine.

I only found one similar (unanswered) question about this on the internet (http://boards.developerforce.com/t5/General-Development/Duplicate-values-not-allowed-with-Solutions/td-p/390493), so I'm curious if anyone else has run into it (not sure if it's an issue with deploying RecordTypes via the ANT Migration Tool?).

EDIT: I've filed a case with Salesforce in case this is a functionality issue.

  • Unfortunately Salesforce support waited 23 days to start looking at this - in the meantime I had to refresh my sandbox where it was happening to complete the rest of the project. Hopefully someone else encounters this so we can get to the bottom of what triggered it and why. – Michael Welburn Jan 3 '14 at 22:01
1

ooo, I've had tough luck managing RecordTypes outside of Salesforce (via Metadata API). You're best bet is to just add Record Types manually on the Object Page in Salesforce.

  • This is my fear, but I'm hoping to get an official this isn't supported from Salesforce before I do anything manually. – Michael Welburn Dec 11 '13 at 19:48
  • 1
    That's exactly what my experience suggests -- you have to manage RecordTypes manually. :/ – Scott Pelak Dec 11 '13 at 19:49
  • I've deployed new record types via Metadata API with no problem. – Daniel Hoechst Dec 11 '13 at 20:20
  • @DanielHoechst the record types gets deployed over the organization without any problem using Metadata API. But I think amatorViae means that we need to ultimately make them manually. I faced the similar situation that after deploying record types I wasn't able to make them visible (Programmatically) over my Profile using Metadata API and that's how we ultimately do. – sanchit Dec 11 '13 at 20:28
  • Can the Salesforce Tooling API's ContainerAsyncRequest do anything in this regard? – sanchit Dec 11 '13 at 20:36
1

please refer link:

https://developer.salesforce.com/forums/ForumsMain?id=906F00000008ozBIAQ

I was facing exactly same issue. I was getting some Bad data for Status of the Case. You need to update Business process on record type, Set it to some other Business process and reset it again back to Process you want]. If you face any issue of "Duplicate Values Not Allowed" please refer link I provided. I have mentioned approach to handle that too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.