0

I have been testing some automation in our qa sandbox with success, I moved the process builder flow, and visual flow into production. Essentially a process builder flow calls a flow and gives it two variables if it meets a certain criteria, the flow then lookups all records in that particular object, and sends an email if no records match this particular record ( I can explain further if it helps later).

Upon moving the process builder flow, and visual flow into production, I have found it to fail at all times when I have tested as both a system administrator and end user.

As an admin I receive the error notification below. The notification isn't helpful for debugging as the error states I should contact support......yet when I call support they are not able to help me as they say visual flow does not come under the basic support plan....so I'm a bit stuck!

"Error element Lookup_Incidents_created_last_6_months (FlowRecordLookup). This error occurred when the flow tried to look up records: An unexpected error occurred. Please include this ErrorId if you contact support: 436519097-20826 (-548403183). You can look up ExceptionCode values in the SOAP API Developer Guide. Flow Details Flow Name: LookupAllIncidentsLast90Days Type: Autolaunched Flow Version: 5 Status: Active Org: Jisc (00Dw0000000nN2S) Flow Interview Details Interview Label: LookupAllIncidentsLast180Days 11/06/2018 15:55 Current User: Glenn Daly (005w0000004x3Ri) Start time: 11/06/2018 15:55 Duration: 0 seconds How the Interview Started Glenn Daly (005w0000004x3Ri) started the flow interview. Some of this flow's variables were set when the interview started. Caller_Email = glenn.daly.survey@gmail.com IncidentId = a2j1r000006gb7BAAQ RECORD QUERY: Lookup_Incidents_created_last_6_months Find one BMCServiceDesk__Incident__c record where: COL_JIS_Caller_Email__c Equals {!Caller_Email} (glenn.daly.survey@gmail.com) Survey_Sent__c Equals true CreatedDateLast180Days__c Equals true Result Failed to find record."

Based on what I understand, the error message is saying that the record lookup has failed. I have checked the three fields that are involved in the lookup; COL_JIS_Caller_Email__c, Survey_Sent__c , CreatedDateLast180Days__c and all are visible to my profile.

I have also double checked that I have access to the BMCServiceDesk__Incident__c object.....and I do.

One thing to note is that if the lookup returns no records, it should then move onto the next step.

Another thing to note is that I have "Assign null values to the variables if no records are found" set to TRUE.

The variable to which the values are assigned is of data type text, and Input and Output.

Is anyone able to help me with this problem, seeing as Salesforce support can't, and the issue didn't come up in our sandbox instance?

  • Did you check the field level security in BMCServiceDesk__Incident__c object for your profile ? – SL man Jun 11 '18 at 16:01
  • Yes I have access to the BMCServiceDesk__Incident__c object – Glenn Daly Jun 12 '18 at 8:08
  • If it helps, when I run the record lookup from the flow as a query in the query editor within dev console, the query runs without error. – Glenn Daly Jun 12 '18 at 8:56
  • They really won't cover this? A GACK isnt something you cause directly, its something going wrong outside of the editable scope you have access too. I would push back on that response. If that doesn't work, start over from scratch, and keep adding one thing at a time until you get the same error message. At least then youll have something to work with. – battery.cord Jun 12 '18 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.