1

We are using Salesforce to Salesforce to share an object (Object A) with the target org. In the target org, the trigger for the object A is invoked and based on the received record, tries to update existing records of another object (Object B). This update fails due to the fact that the Connection User does not have access to some of the fields of Object B. Is there a way to give access to the Connection User to modify a field for a given Object?

  • I suppose you can either provide permissions of object fields on the profile or can create a permission set and assign permission in that. Have you tried this? is it achievable? – Mr.Frodo Jun 11 '18 at 14:28
  • The issue is that Connection User belongs to a profile called Partner Network and this profile can not be viewed or modified (even when I get the Id and try to see the profile or user record I get "Insufficient Privileges" and I am the System Admin) – Payam Izad Jun 11 '18 at 14:34
  • On permission sets, I can not select the Connection User to assign to permission set to. So unfortunately both options are not achievable. – Payam Izad Jun 11 '18 at 14:44
0

The Partner User profile can’t be modified, but you can clone it or create permission sets to specify what partner users can do.

So clone your Partner Profile and assign it to the Connection User, so you can modify the cloned profile or assign permission sets with permissions needed.

  • Thanks Rajesh, just to clarify, is the Partner User Profile the same as Partner Connection Profile? Also, how can I assign a new profile to the Connection User given that I can not view or query the Connection User? – Payam Izad Jun 11 '18 at 16:21
  • Actually no, they are not the same. My bad I didn't go through the comments properly. When you enable Salesforce to Salesforce, a new user named “Connection User” is created. The Connection User is automatically assigned to the Partner Network profile. The Partner Network profile cannot be modified and is not included in any profile management view. – codeyinthecloud Jun 11 '18 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.