0

I am developing an application using MCCordovaPlugin and just updated to v.1.0.3.

All of the functions work well, but there is a problem : if using this updated MCCordovaPlugin, the app will crash on iPhone 5 with OS ver : 10.3 once I open the app. When I was using v.1.0.2, it didn't crash at all.

It happened when I installed the application through TestFlight. When I installed the application directly from XCode it still worked.

Please find the crash log here.

For device with OS ver. 11.2 or 11.3 (tried in iPhone 5s, 6, 7) worked just fine when installed the app from TestFlight; not crashed.

Currently I am also using Salesforce Mobile SDK Plugin (v.5.3.0) for the application authentication.

More info :

Cordova version : v.7.0.1, iOS version : v.4.5.4

Kindly advise about this matter. Thank you so much for your help!

Regards,

2

We’ve released version 5.1.1 of the SDK which addresses a crash on armv7s device (like yours). Based on the crash log, we’re not precisely sure that it is the same crash (no symbols were generated) but it is the only issue we know of that affected armv7s devices.

As this is not part of the publicly-available Cordova plugin, you’ll need to integrate manually.

Grab the latest .bundle and .framework file here https://github.com/salesforce-marketingcloud/MarketingCloudSDK-iOS/tree/master/MarketingCloudSDK and replace the ones in your sdk-cordova-plugin in src/ios/MCPushSDK. Then re-run code to set-up your project and add plugin, platforms to your project.

Hopefully this will resolve this issue.

  • Hi Tom, this has indeed resolved the issue. Thank you for your help! :) – Gabriela Devita Jun 8 '18 at 6:24
  • Anytime my friend! – Tom Brooks Jun 8 '18 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.