0

I have Single Sign-On in my org and we prevent regular login. I made a sandbox and my login is failing using myusername.sandboxname

I can't figure out how to log in - I would need SSO, right? But to use SSO, I use my domain, which logs me into Production.

I saw a forum with somebody with this same issue in 2013, and the resolution was to somehow make yourself (admin) an exception to SSO, but I can't figure out how to do that - thoughts? Thank you!

1

If you have Delegated Authentication enabled, you can't bypass it with the trick sfdcfox posted. You need to use a user that doesn't have SSO enabled. If you don't have one and have already refreshed your sandbox, you will need to create a user and then refresh or create a new sandbox.

Note: it is good practice to have a "break in case of emergency" user that doesn't have SSO enabled so you can log into your production org in cases where the SSO provider is down.

  • Thank you for your answer - as mentioned, I've heard of this solution before, but I don't understand how to make myself exempt from SSO enabled - can you elaborate on how to do this? – Natalie Paige Jun 1 '18 at 22:29
  • Also, it's disabled from using standard non-SSO sign-on, so would I still be able to log in if I were SSO-exempt in the way you're referring? – Natalie Paige Jun 1 '18 at 22:30
  • The way we do it is have a permission set that enables SSO. We don't have SSO turned on on any profiles. Every user except the one that you need to manage sandboxes gets the SSO permission set. – Daniel Hoechst Jun 4 '18 at 15:29
0

You can override this by using the login parameter:

https://mydomain--sbname.my.salesforce.com?login

The extra parameter should allow you to log in.

  • hm...says it's not found :( "<mydomain>--<sbname>.my.salesforce.com’s server IP address could not be found. DNS_PROBE_FINISHED_NXDOMAIN" – Natalie Paige Jun 1 '18 at 20:02
  • obviously with actual values .... :) – Natalie Paige Jun 1 '18 at 20:02
  • @NataliePaige You can also try https://test.salesforce.com/?login. This works on my sandbox. – sfdcfox Jun 1 '18 at 20:08
  • No, ultimately this brings me to production since it's the same issue I've stated -- that when I click "use custom domain" it logs me into prod (because regular sign in is disabled, so I need to use SSO) – Natalie Paige Jun 1 '18 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.