0

I have a community user who needs to hit a chatter rest api endpoint. Is there any way to test if the user can hit the api.

It is a community user so i cannot use workbench.

  • Why does your community user need to access chatter rest endpoint? He can use chatter ui. – Pranay Jaiswal May 23 '18 at 20:13
  • Actually he needs some user details in his community page. Can we do that by chatter ui? @PranayJaiswal – user55791 May 23 '18 at 20:18
  • Can you provide what details? It can happen we can querry and display it no need to access rest API. Is it lightning community or classic VF+Apex community. – Pranay Jaiswal May 23 '18 at 20:37
1

You don't need workbench to access any REST API endpoints. What you need is:

As long as you have the pre-requisite, any User set in Salesforce will be able to access REST API endpoints.

  • I have another added question. I was trying to access the following endpoint /chatter/users/batch/0051I000000cKfWQAU Here 0051I000000cKfWQAU is a user Id. What is happening is that the address fields are coming up as null. However, if I use /services/data/v41.0/connect/communities/0DB290000004CaOGAU/user-profiles/00529000001vEWK, adress fields are coming up properly. Is there any particular reason this is happening? The end points are being hit by a community user @JayantDas – user55791 May 23 '18 at 20:15
  • Because the original question and the one in your comment are totally different, I would recommend to post this as a separate question with more details so that it can be looked upon. – Jayant Das May 23 '18 at 20:23
  • can i modify this question? Do you know the answer? I am allowed to post only once every 40 minutes @JayantDas – user55791 May 23 '18 at 20:25
  • Considering your limitation, you may like to edit your original post and put numbers to your questions. As for your other question, are you sure you are using the same user id in both the endpoints, at least the ones you have provided here don't seem to have the same ids, and that may be the reason. – Jayant Das May 23 '18 at 20:32
  • I tried with the same Ids. Ok let me try this. Can it be a permission issue of the user field had both the urls not worked? @JayantDas. I apologize for the messy question, but I a very new to integration – user55791 May 23 '18 at 20:37
1

I presume that you are attempting to test the connection to the Chatter API REST Endpoint. You could use the following tools to verify your connection and get a sense of the expected request and the JSON response returned.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.