This seems like an easy thing that i'm absolutely pulling my hair out over.

I have a couple of back office workers that need access to edit Opportunities (two fields only) - Ive set up a page layout just for them - so they only see what they need to. My issue is these people need to be able to edit two fields. I keep getting

insufficient access rights on object id

error. I have their Profile with no access to Opportunities and set up a permission set Opportunity Permission with Read, Edit and View access and selected Field Permission - Edit Access on the fields I want the user to be able to edit.

They can view the Opportunity fine and can access the field to edit it but the error is displayed on saving the record.

On field Level security these are Visible and Field Accessibility they are Editable.

I'm happy to create a new profile if that is needed. The opportunities are created by users higher on the hierarchy.


EDIT I raised a case with Salesforce and I had "Edit Read only Fields" selected on the user Profile - I shouldn't have cloned their profile from my admin profile - Rookie mistake... Thanks for your input guys

3 Answers 3


IF OWD for Accounts and Opportunities is Private:

Even User have edit access from object level, they can not update the record until they have Read/Write sharing on that record. So, please share the record with two user by using Sharing Rule or manual sharing (Sharing button on record).

OWD for Accounts and Opportunities is Public Read-only:

In that case, issue should not happen. May be this known issue is causing problem: https://success.salesforce.com/issues_view?id=a1p3A000000eq6pQAA. If not so, log a case with Salesforce.


You already have correct access rights through permission sets. So if the user has edit access to the record then he can edit the field.

Issue here is, user has Read Only access to the record that's why he cannot edit the record.

You can create a sharing rule or manual sharing or team based sharing to provide Read/Write access to the Opportunity record, and then only user will edit the fields.


To Edit other users record OWD need to be Public Read/Write. To check record access, you need to go in to Setup and go to Sharing Settings. Set it to Public Read/Write. If you want them to edit their own make it public read.

  • it is not advisable to change the OWD until and unless it is absolutely needed. Commented May 16, 2018 at 5:07
  • @SantanuBoral yes it depends on OP> Commented May 16, 2018 at 5:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .