0

On the site where the Salesforce's Chat UI pom file is hosted (here) the SSL certificate just expired, making the builds fail with the following error:

Could not resolve com.salesforce.service:chat-ui:3.0.0.

Required by: project :app > project :react-native-salesforce-chat

Could not resolve com.salesforce.service:chat-ui:3.0.0. Could not get resource 'https://salesforcesos.com/android/maven/release/com/salesforce/service/chat-ui/3.0.0/chat-ui-3.0.0.pom'. Could not GET 'https://salesforcesos.com/android/maven/release/com/salesforce/service/chat-ui/3.0.0/chat-ui-3.0.0.pom'. sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed

enter image description here

Could you tell me if there is any workaround for this?

1 Answer 1

1

They have in their documentation:

NOTE: The certificate for the server used for our original Snap-ins SDK repository just expired. We've changed the location of our repository. Workaround: Replace the salesforcesos.com maven repository in your gradle scripts to

https://github.com/forcedotcom/ServiceSDK-Android/releases

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .