1

I have created a query activity in Salesforce Marketing cloud and it executes without any issue from the front end and log data to the relevent Data extension. But when I try to execute the same query activity via the SOAP API, I get below error response. But I could Create the query activity via the SOAP API without an issue.

 <?xml version="1.0" encoding="utf-8"?>
<soap:Envelope
    xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"
    xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"
    xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <soap:Header>
        <wsa:Action>PerformResponse</wsa:Action>
        <wsa:MessageID>urn:uuid:1c2a4754-66ef-42c4-b3f9-b50f15b91c1e</wsa:MessageID>
        <wsa:RelatesTo>urn:uuid:0e99dde3-cd89-4217-9b6c-425f0f5f846b</wsa:RelatesTo>
        <wsa:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To>
        <wsse:Security>
            <wsu:Timestamp wsu:Id="Timestamp-9f926599-f804-4127-8813-465e49241483">
                <wsu:Created>2018-05-09T11:05:14Z</wsu:Created>
                <wsu:Expires>2018-05-09T11:10:14Z</wsu:Expires>
            </wsu:Timestamp>
        </wsse:Security>
    </soap:Header>
    <soap:Body>
        <PerformResponseMsg
            xmlns="http://exacttarget.com/wsdl/partnerAPI">
            <Results>
                <Result>
                    <StatusCode>Error</StatusCode>
                    <StatusMessage>Exception occurred during [Perform::Start] ErrorID = 1973006251</StatusMessage>
                    <ErrorCode>9999999</ErrorCode>
                    <Object xsi:type="QueryDefinition">
                        <PartnerKey xsi:nil="true" />
                        <ObjectID>ab058e56-b8d4-4773-8acc-c13b804be3cc</ObjectID>
                    </Object>
                    <Task>
                        <StatusCode>Error</StatusCode>
                        <StatusMessage>Exception occurred during [Perform::Start] ErrorID = 1973006251</StatusMessage>
                    </Task>
                </Result>
            </Results>
            <OverallStatus>Error</OverallStatus>
            <OverallStatusMessage />
            <RequestID>5846ccfd-ecf6-4cf8-b614-369c73ee6b26</RequestID>
        </PerformResponseMsg>
    </soap:Body>
</soap:Envelope>

Appreciate your support.

  • I cloud solve this issue by setting my working Business Unit as the Default Business Unit. – Dinesh Wickramasinghe May 9 '18 at 12:56
  • 1
    If that's the case then you can use the ClientID attribute in the request and it will work as you intend it to – Amtera May 9 '18 at 16:26
  • @Amtera, Yes you are correct, I added the ID of the BU to the request. – Dinesh Wickramasinghe May 14 '18 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.