In all six table components in my LE dashboard (Summer'18 preview sandbox), I see as the last item an empty blue row. Is there a way to get rid of this? I tried limiting the number of groups, but that does not help.

When I look at examples on the Interwebs, I see tables without such a row, so I wonder what is special about my dashboard or reports. Does anyone else see this in his/her dashboard or am I the only one?

LE Dashboard table component

Edit I am beginning to suspect that this is a bug/feature thing. Below a figure from the Summer'18 release notes. Note the last row. Why is this so annoying? Because without the last empty row, a scrollbar would not be shown. The scrollbar takes away valuable space (I have many adjacent dashboard components, I need all the space I can get). I need to show several "Top-n" tables, e.g. Top-10 opportunities, but this way, you always see either 10+1 or 10 with a scrollbar.

Image from Release Notes

  • 1
    What is the first column configured in your reports which shows 1, 2, 3....? Is this coming from any field? Have you tried removing that? I created a report in Tabular Format and couldn't really see the blank row as mentioned in your issue.
    – Jayant Das
    May 15 '18 at 2:31
  • Good point. If I go to the report (via the link in the dashboard) then no numbers are shown. And no last empty row, just a row with a Grand Total. Try adding your report to a dashboard and see what it looks like. I bet it will have a new first column with row count and a new last empty row. Somehow adding a report to a dashboard gives you these features for free. May 15 '18 at 6:28
  • Also: the grand total is stripped from the report when you add it to a LE dashboard. People are not amused by this: success.salesforce.com/ideaView?id=0873A000000E4bzQAC May 15 '18 at 6:33
  • Editing the report that is used in the dashboard (in the Report Builder) shows the row count column and last empty line as well. Run the report and they are gone. Add it to a dashboard and they are visible once more. Strange. May 15 '18 at 7:09
  • 1
    Yeah I had kind of figured that after looking at your Edit section (you may like to update your post reflecting Summer 18). Unfortunately, don't have visibility on the preview sandbox but definitely looks like to be introduced with Summer 18, because with Spring 18 it just works fine with no unwanted first column and blank last row.
    – Jayant Das
    May 15 '18 at 14:20

And before we lose track of how it looked like in Spring 2018, below is a sample Table Report which does not have any "first column showing numbers" or any "blank row at the bottom" of the report either in the report or the dashboard as seen in your screenshot from Summer 2018.

This issue definitely is with Summer 2018.

Actual Report enter image description here

When viewed on Dashboard enter image description here

  • 1
    I got a mail from Salesforce: "We are fixing both issues that you have reported in the next Summer '18 patch - both extra row and column will not show up on tables after the fix." May 28 '18 at 6:09

Turns out that this is a Summer'18 preview bug/feature. Thanks to Jayant Das for pointing me in that direction. I made a similar report and dashboard in a Spring'18 sandbox and there: no first column with row count, no last blue, empty row. It just looks like how I want it to look like.

So now we hold our breath, cross our fingers and wait what our dashboards will look like in the final Summer'18 version.

  • 1
    You really should accept Jayant's answer and award him the bounty since he's the one who figured this out. If you're not going to award the bounty you never should have offered it.
    – gNerb
    May 17 '18 at 14:02
  • Well, I offered the bounty because my question did not get any attention whatsoever. In that, I succeeded. But you have a point and I don't want to waste 100 points, so I awarded them to Jayant. And by awarding them, I automatically accepted his answer (which is not what I wanted, but what the heck). May 17 '18 at 14:06
  • Thanks @gNerb & Sander de Jong - tbh, I had forgotten that this question had a bounty of 100 points!!!! But awesome to see the spirit of this forum. I am learning everyday here. Unfortunately the correct answer for this question is with Salesforce but definitely looking back a release helped to at least identify and confirm the issue.
    – Jayant Das
    May 17 '18 at 14:16

As of 2018.10.30: From "Reports" > "Report Name" column, click on the desired report > Click on the Gear Button > the "Options" pop up window appears and you are able to uncheck "Grand Total" row

The Options pop up window The Options pop up window After unchecking the Grand total box and clicking Apply, the grand total blue row at the bottom disappears After clicking Apply, the grand total blue row at the bottom disappears

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.