1

At the bottom of the Connected App Details Page I created a simple Custom Attribute:

enter image description here

It's fairly simple, I just wanted to test and get the Nickname.

Now, when I go edit the Connected App Policy, I'm not able to select a Custom Attribute. In fact, I only get the option of None:

enter image description here

What step am I missing?

Thank you.

  • Is it not possible to have something other than None, in the Custom Attribute ComboBox (after selecting Custom Attribute for Subject Type)? This is odd. – JustLooking May 7 '18 at 15:05
  • It looks like I discovered the holy grail of questions, something that is so hard and misunderstood that no one on earth knows. Yay me! – JustLooking May 29 '18 at 15:19
  • Experiencing the same issue here. It is very odd. – BrBarr Feb 18 '19 at 22:25
  • When trying to make the change using sfdx, I get the following error Error parsing file: 'CustomAttr' is not a valid value for the enum 'SamlSubjectType' (14:54) even though the docs clearly state that it is the enum for the selection https://developer.salesforce.com/docs/atlas.en-us.api_meta.meta/api_meta/meta_connectedapp.htm – BrBarr Feb 18 '19 at 22:28
1

IMO, this is super confusing. The Custom Attribute option allows you to select a field on the user object and is not related to the Connected App's Custom Attributes section.

Create a custom field on the user object that aligns with the Subject that you need and it should be selectable in the Custom Attribute picklist on the connected app.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.