0

When i add custom profile to package its show N/A . Also when this package is installed in another org (testing org), It is not displayed at all to link profile settings to any profile

1 Answer 1

1

Took me a while to figure it out but here's the solution:

IN YOUR DE ORG:

  1. Clone Standard Platform User profile (because is the one that has the Salesforce Platform license) an name it something meaningful like MyApp_Profile
  2. Customize MyApp_Profile to match your desired access level for the users that will test or use your app
  3. Add custom profile settings MyApp_Profile to the package
  4. Go ahead an finish the package

IN THE TEST_ORG (OR YOUR_CUSTOMER_ORG):

  1. Pre-create a profile by cloning the Standard Platform User profile and name it something meaningful like MyApp_TestProfile
  2. Assign MyApp_TestProfile to a user
  3. Install the package and on Step 2 (Choose security level) of the wizard you have to select the third option (Select security settings)
  4. Under "Customize security" section make sure the MyApp_TestProfile (created on step 5) has the MyApp_Profile assigned (created on step 1)
  5. Finish the Package installation
  6. Log to the test or customer org with the user that has the MyApp_TestProfile assigned and choose your App from top right menu.

I hope this solves your issue too!

1
  • When I add my profile setting in package it gives N/A. Also when I install package on test instance It does not show my profile settings at all. Is there some settings to add profile settings ? May 1, 2018 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.