1

I have been using Talend for about two years to load data into Salesforce from files and have not had an issue. All of a sudden, over the weekend it has stopped working with about 20 of my standard loads (to different orgs).

Initially I got this error

"Exception in component tSalesforceOutputBulkExec_1_tSalesforceBulkExec (CustomerLoadSourcesNoEmail) org.talend.components.api.exception.ComponentException: UNEXPECTED_EXCEPTION"

I tried to just re-connect with a basic connection element and got this

"IOException: com.sforce.sw.ConnectionException: Failed to get next element"

Error Message

I tried to use meta data to connect

"IOException: com.sforce.sw.ConnectionException: Failed to send request to"

enter image description here

I assumed the issue was Talend or Java update so I have tried everything from rolling back java, reinstalling from scratch to installing on another fresh computer.

Current setup is:

  • Windows 10
  • Talend 7.01.20180411_1414
  • jdk1.8.0_171

So I am starting to get the feeling it might actually to do with a Salesforce release and not Talend or Java problem.

I noticed this old article with the same error https://developer.salesforce.com/forums/?id=906F00000008yx5IAA

Anyone seeing anything like this recently?

1 Answer 1

3

The Endpoint URL needs to be https://login.salesforce.com/services/Soap/u/39.0 due to recent changes in salesforce.

2
  • Wow, I just lost a day of my life. I tried a bunch of end points, why does only 39 work?
    – Kris Moyse
    Commented Apr 23, 2018 at 21:28
  • Ok not one that works, actually just need to change the default from talend from www to login. I get it. Wow, the error message could be clearer :)
    – Kris Moyse
    Commented Apr 24, 2018 at 4:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .