3
  • Clone a Sandbox is a new feature as of, I think, March 2018.
  • I am cloning .dev sandbox.
  • My prod username is [email protected] (i know this username is stupid, but it is the situation)
  • My .dev username is [email protected]

I know there is an issue with logging into cloned sandboxes https://success.salesforce.com/issues_view?id=a1p30000000T4hLAAS But the workaround is to login at: csXX.salesforce.com

  • What is my username and which box would my password have come from?

Seems like a silly question but the I cannot get access, have tried every combination, and forgot password. Next is to create another sandbox. Never got an email when the sandbox was created, so it is like my email was also obfuscated. hoping sandbox just replicates in a few hours.

  • Anyway... What is my expected username and which box would my password have come from?
4
  • 3
    I'd expect it to be [email protected] or possibly [email protected]. At least according to Create a Sandbox. The password would come from the cloned org. Commented Apr 23, 2018 at 6:04
  • Clone a Sandbox (Beta) has the same note about the sandbox name being appended to the usernames. Commented Apr 23, 2018 at 6:06
  • Hi Dan, That was my expectation too. However it did not work any way. I think it might be a bug. However I tried again with another org and it worked fine. I will display what worked in my Answer. But I cannot answer why it did not work for me the first time Commented Apr 23, 2018 at 6:54
  • I tried even in four or five sandbox and it was impossible, even trying to go in through the sandbox menu...
    – Carloss
    Commented Apr 23, 2018 at 9:48

2 Answers 2

0

So after testing in Another org logging in worked just fine, using this username as expected. [email protected]

typically people would use the below convention as most of you would not have .prod on your prod login.

[email protected]

I assume my password came from prod also (like the user name), in my second test my sandbox and prod passwords were the same as each other

Update Feb 2024:

Had the same situation on a new client, and the Sandbox that is cloned provided the Password.

And the Username is as expected on any new sandbox [email protected] the username on the cloned sandbox was: [email protected]

It was NOT :

I repeast Not "[email protected]"

only the last suffix changed, which is what should happen.

again the password came from the cloned box not from production.

1
  • Check my updated answer. I cloned a sandbox today, and it works as I said. Commented Feb 25 at 19:09
0

So, this problem can be confusing, and I wanted to share the simple solution.

Let's assume the source sandbox is called "uat", and the cloned sandbox is called "uatclone".

Go to the source sandbox and find the user you want to log in using username/pw. If the username is:

[email protected]

The cloned sandbox username will be:

[email protected]

The password in the cloned sandbox will be the same as the source sandbox. Of course, the user must exist in the source sandbox at the time of the cloning, or this will not work.

Special Note: You may want to change your password before the clone in the source sandbox in case there is some sort of password restriction that is being enforced in the clone, and you have an SSO that's getting around that.

Update -- Since this is being downvoted and challenged by the OP, I want to demonstrate with screenshots.

During sandbox creation, the newly created sandbox will manipulate the second suffix. So, if your username is:

[email protected]

your cloned sandbox would yield:

[email protected]

  1. First, I check my username in the SOURCE sandbox which in this case is UAT. Notice it ends in .uat - so assume the username is: [email protected]

enter image description here

  1. Then, I made a sandbox as shown in the "Copied From" column (last one) from our UAT:

Sandbox Created from UAT

  1. NOW FOR THE CONFUSING PART. Which is why this question exists! When I click the "Log In" link shown in the screenshot from PROD, Salesforce will incorrectly assume the sandbox was copied from PROD. However, as shown above it was copied from UAT. Some production usernames in our org have a suffix of .prod (bad practice imo), and the cloned sandbox assumes my username is [email protected] . For me, I cannot log in to this sandbox at all with this username. Attempted to log in to new sandbox

  2. Recall Step 1. I checked my username in the SOURCE sandbox. Now, let's try to log in with the convention I suggest... which is [email protected] IT WORKS! Now, lets check what my actual username is to verify:

Checking username in new sandbox

  1. Also, I checked other usernames that end with .uat in the source sandbox and have confirmed they also have the same convention [email protected] . I also created a listview to see if ANY username had .prod in it.

username Listview

  1. Na da.

No users match the criteria

Point is it appears to manipulate the second suffix beyond the sandbox name.

As a side note we are not on Hyperforce, but we are on Spring '24 API version 60.

3
  • 1
    This is incorrect. Back when I created this question the sandboxes were creating incorrectly. now in 2024 they are creating as expected. the new uatclone sandbox will have a username like [email protected] Commented Feb 25 at 8:35
  • This is how it works for me. I just cloned a sandbox yesterday. The org is not on Hyperforce though, so maybe something is different. I can 100% confirm it works this way though. Commented Feb 25 at 17:00
  • @TheArchiecta - I think we're saying the same thing in two different ways. I was addressing the assumption that somehow .prod would get carried into the cloned sandbox as stated in your original answer. Commented Feb 25 at 22:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .