6

We are in the process of converting a Customer Portal into a Customer Community and we are having issues with the 404 redirect function of Communities.

Using Customer portals when a user enters in an invalid URL they are redirected to a visualforce error page, this works perfectly.

Assign Error Pages Setup

When we convert to communities however with the same setup the 404 redirect transfers to the standard salesforce page not found error within the Standard Community. This is an issue as this breaks the look/feel as we are using all visualforce for this portal.

Standard 404 Error

Has anyone come across this before or have any ideas of how to fix this? There is the redirection setup within the force.com setup but you would need to know the Url the user is typing, as far as I am aware we cannot do Regex based redirection using that functionality.

3
  • I didn't get a confirmation one way or another in the Success Community either, so I created an Idea for it: success.salesforce.com/ideaView?id=08730000000l3uPAAQ Apr 11, 2014 at 15:54
  • Was this ever resolved? I am dealing with the same problem today.
    – user10119
    Jun 25, 2014 at 21:34
  • @MichaelWelburn I see your idea has been marked as "Delivered" in the Winter '15 release. However, we are still experiencing this issue. Were you ever able to resolve this?
    – Matt
    Nov 6, 2014 at 17:25

2 Answers 2

1

I take it that this is the 404 page for an authenticated Salesforce Community user? If so, this is a known issue with Communities that requires Salesforce to make changes to the way that communities work so that your own 404 page is shown to the authenticated user. I'd suggest raising a case with Salesforce to make the issue visible such that it may be fixed in a later Salesforce release.

2
  • Yes this is related to the 404 or "page not found" error for authenticated users. You say that this is a known issue for communities but I could not find any information to support that claim, if you could point me in the direction of any information supporting that conclusion it would be much appreciated.
    – Mitch Hunt
    Dec 2, 2013 at 22:06
  • I'm sure that if you raise a case with Salesforce about the issue (and that issue moves past first level support to product development) that it won't be the first time they've heard the issue being raised. At a previous Salesforce implementation engagement the client raised a case about the same issue with Salesforce.
    – beamso
    Dec 3, 2013 at 4:50
0

I was struggling under same situation and the solution that i have found was check and uncheck the boxes below under the site settings.

Setup --> User Interface --> Sites and Domains --> Sites

Clicked Edit, Unchecked all checkboxes, saved, loged, checked again and it worked.

(Ps: to test my authentication i've been using the anonymous tab from my browser to avoid any cached or session or whatever)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .