0

I was playing with workbench and tried to create job in "Rest Explorer". The Url I was using:

/services/data/v41.0/jobs/ingest/

The Request Headers:

Content-Type: application/json; charset=UTF-8
Accept: application/json

Request Body:

{
  "object":"Contact",
  "contentType":"CSV",
  "operation": "insert",
  "concurrencyMode": "Serial"
}

I was executing a POST request. However I received this error "Property currently unsupported: 'concurrencyMode'"

Anyone has any ideas? Many thanks.

  • You may need to upgrade to API version 42.0, does that make any difference? '/services/data/v42.0/jobs/ingest/' – Raul Apr 10 '18 at 6:33
  • Not really. The highest version is 41.0 and I tried with 42.0 actually, but it doesn't work. – Vera Apr 10 '18 at 19:24
  • hi @Vera I am also facing the similar issue, by any chance do you know how to set concurrency mode to serial via rest api? – Manish Mehra Jul 28 '18 at 7:35
0

I also got the same error, maybe it is not exposed through REST API or WorkBench.

But as per this trailhead Use Bulk API to create a job in WorkBench you don't have to pass concurrencyMode attribute. By default, it is set to Parallel.

enter image description here

Click Execute and check out the response.

enter image description here

  • So cannot set it to Serial with REST API? – Vera Apr 10 '18 at 18:00
0

I was able to solve this finally. Looks like Salesforce was expecting the xml attributes to be passed in same order. Order change was causing the problem for me and was returning 400 Bad Request Error.

<jobInfo xmlns="http://www.force.com/2009/06/asyncapi/dataload">
                <operation>insert</operation>
                <object>SomeObjectName</object>
                <concurrencyMode>Serial</concurrencyMode>
                <contentType>CSV</contentType>
</jobInfo>

As shown above Serial has to be after object attribute and before contentType.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.