4

After retrieving and unzipping metadata from my sandbox, I ran the command to convert it to the DX model. Using force:source:push doesn't work as expected, as I get a looooooooong error log, mainly because objects aren't deployed. I've found that the error is this one:

Cannot specify a gender for a gender neutral language

I've tried to specify a language attribute to my .json configuration file, and then the scratch org is created with the default language of Brazilian Portuguese (which isn't gender neutral). Doing this changes nothing, the problem still happens.

Will I need to manually edit every object file definition to remove the gender, or is there a configuration on the scratch org to allow this deployment?

1

Managed to solve this issue by specifying the language parameter as pt_BR. At first, I thought this didn't solve the issue because the error log was huge still. But after trying it again, and inspecting the log for this error, I've seen that it does not occur anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.