I am using sublime and mavens mate combination. When I am trying to save an existing component, It is giving the following error: "Could not update lightning components: Cannot read property 'Id' of undefined".

I tried to clean the project and tried to delete .lightning file config folder, but they ddnt work. Can anyone please suggest a workaround for this ?

  • 1
    refresh the metadata index and update project this will resolve your issue, this happens when we create a new component using MavensMate. Apr 5, 2018 at 3:58

1 Answer 1


In my experience, there are two ways to get this error:

  1. You created your component using the Developer Console and after you refresh your metadata index and Update the project, then when you save any change the error shows.
    • To solve this error, you need to go to config folder and delete the .lightning file.
  2. You created your component using Mavensmate, so when you try to save the error appears.
    • Here you only need to Refresh your metadata index and Update your Project.

For me was the first error and that's why I tried to sum it up in this post. Hope this help.

  • Can you please explain where is .lightning file?
    – Raphael D
    Jul 22, 2019 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.