0

I created a new VisualForce page - an exact copy of the last one I developed, but with a different name and the same controller code, but with a different name. So, now I want to create a new package (due to the last one not working properly with constantly changing names of classes following a naming convention). But I cannot see my new page in the Package Manager. I could see it in the list of VF pages in Setup and I have assigned all the neccessary user permissions to it. Why am I not able to see it in the list in the Package Manager, this is strange to me, as I am following the exact same procedure and order of doing things as before. Any ideas would be appreciated.

  • 1
    Are you sure it's not already in the manifest? If the page has dependencies on existing objects, it would have been automatically included. – sfdcfox Apr 2 '18 at 23:48
  • By manifest do you mean the list of available pages/classes etc. within the Package Manager? – mirantii Apr 3 '18 at 22:08
  • Yes, check the list of current components in your package. Typically, you'd see that the dependent components are automatically included. – sfdcfox Apr 3 '18 at 22:22
  • So, what I am trying to add is a VisualForce page and when added it automatically adds its controller. The problem is I cannot see the page itself. I just tried creating a blank page (nothing inside) and see it will appear, but apparantly it is not appearing either. I enabled all possible profiles. May be I must enable something else? – mirantii Apr 3 '18 at 22:34
  • Permissions on an object have absolutely no effect on if you can add something to a package (you do need to have the ability to create/manage packages, though). I've never heard of a situation where you can't add a particular visualforce page to a package. I think some screenshots might help out here. – sfdcfox Apr 3 '18 at 22:46
0

Some components are not automatically added to the package:

https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/packaging_components_auto_added.htm

Try to add the new VF and controller class using the standard procedure:

https://help.salesforce.com/articleView?id=adding_package_components.htm

  • The thing is page is not visible to be added, it is not that it is not added automatically, I cannot add it manually – mirantii Apr 3 '18 at 23:15
0

It appears that you need to go to the next page. Look at top-right corner of the list for the previous/next page options, or click on "V" in the "Rolodex" to show pages that start with V:

Pagination and Rolodex feature

  • So, basically the problem was that I was pressing on Next Page, but as nothing happened, I thought these are all the pages that are available. Basically, I just renamed the page to start with an A, so it could appear above on the list. But this is a temporary solution. I thought this might be a browser issue ( I am using Chrome), so I tried FF, button still does not work. Have you heard of anyhing like this before? – mirantii Apr 4 '18 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.