0

i tried with the follwing Saop request

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
 xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Header>
   <wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis- 
     open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
       <wsse:UsernameToken>
       <wsse:Username>test123@gmail.com</wsse:Username>
          <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis- 
        200401-wss-username-token-profile-1.0#PasswordText">****** 
       </wsse:Password>
       </wsse:UsernameToken>
       </wsse:Security>
        </soapenv:Header>
        <soapenv:Body>
         <RetrieveRequestMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
          <RetrieveRequest>
              <ObjectType>DataExtensionObject[Test DE]</ObjectType>

                <QueryAllAccounts>true</QueryAllAccounts>

      <Properties>Email</Properties>
      </RetrieveRequest>
   </RetrieveRequestMsg>
     </soapenv:Body>
     </soapenv:Envelope>

       I always get the following response


      <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" 
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
      xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
       xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" 
         xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401- 
        wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis- 
       open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
      <soap:Header>
      <wsa:Action>RetrieveResponse</wsa:Action>
      <wsa:MessageID>urn:uuid:a5cc51af-790e-4876-8e35- 
     b47c09a06dce</wsa:MessageID>
      <wsa:RelatesTo>urn:uuid:123ad64f-08cf-46c6-bc9e- 
    21677d3ef3cc</wsa:RelatesTo>


          <wsse:Security>
      <wsu:Timestamp wsu:Id="Timestamp-81bacc7d-fc78-4a1d-8b72- 
         5d1d8120240e">
        <wsu:Created>2018-03-30T07:58:23Z</wsu:Created>
        <wsu:Expires>2018-03-30T08:03:23Z</wsu:Expires>
         </wsu:Timestamp>
         </wsse:Security>
      </soap:Header>
      <soap:Body>
        <RetrieveResponseMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
         <OverallStatus>Error: Invalid object name 'C100010308.Test DE'. 
        </OverallStatus>
        <RequestID>80902d85-ee8d-4b82-9c97-ddfdfb04881d</RequestID>
        </RetrieveResponseMsg>
       </soap:Body>
        </soap:Envelope>
  • Is 'Test DE' the DataExtension name or is it the ExternalKey/CustomerKey? – Mike Mar 30 '18 at 14:15
  • I cannot reproduce this status despite my best efforts. – Mike Mar 30 '18 at 14:24
  • @mike Test DE is Data Extension Name i tried with External key also didn't work – ravi Mar 30 '18 at 14:30
  • Did it work for you? I am also getting the same error. – user36778 Aug 28 '18 at 7:35
1

You need to set the ClientID tag of the WSDL equal to the parent MID in order to access the shared Data Extension.

E.g. <ClientID> MID_Of_Parent_BU</ClientID>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.