1

I have a problem while deploying a new Big Object to my developer ORG from my windows machine. I was doing the exact steps mentioned in Trailhead and deploying the big object using Workbench. I have created the objects and permissionsets folder and put the object file and permissionset file respectively and created the package file on the root directory, then i make a zip folder of the folders and that zip folder was selected as the source file of workbench and selected the options Check only and Single package. Then going further i got this error message No package.xml found

enter image description here

It would be a great helpful to share what went wrong.

  • Did you zip up one of the inner folders of your source tree? You need to zip the top level directory that encloses package.xml and all of the subdirectories. – David Reed Mar 27 '18 at 10:22
  • Yes i have zipped the main folder which consists of the two folders and the package file. – vivek c Mar 27 '18 at 11:00
0

Are you on a mac?

From the note in the lesson:

Macs create hidden files when you zip up files and folders that interfere with deployment. If you run into a “No Package.xml Found” error, it’s probably because of those hidden files. Create a .zip file without those hidden files using the Terminal command zip -r -X YourZipFile.zip * while in the directory of the folder you want zipped.

Easiest way to do that is launch terminal from the folder where you have your package.

To enable launch terminal from folder go: System Preferences and select Keyboard > Shortcuts > Services. Check "New Terminal at Folder"

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.