0

If I try to schedule an automation I use Schedule method and works perfectly if I'm working on the parent business unit of an enterprise account. If I try to schedule an Automation that is created on a child business unit it will just not work. The API response will reply back with an "OK Program scheduled" response, but the automation is not scheduled. I'm attaching the SOAP request and response for reference.

REQUEST

<?xml version="1.0" encoding="UTF-8"?>
<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" xmlns:a="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:u="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
   <s:Header>
      <a:Action s:mustUnderstand="1">Schedule</a:Action>
      <a:MessageID>urn:uuid:009a92da-042d-4ff9-bf80-0bbc66cd13c1</a:MessageID>
      <a:ReplyTo>
         <a:Address>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</a:Address>
      </a:ReplyTo>
      <VsDebuggerCausalityData xmlns="http://schemas.microsoft.com/vstudio/diagnostics/servicemodelsink">uIDPo84UCuEoy1FHmFNYlofBhioAAAAAks9ugm4Lw0Sgrb3pIykVXN3cJw0eFANJqNC0WAX0P0YACQAA</VsDebuggerCausalityData>
      <a:To s:mustUnderstand="1">https://webservice.s7.exacttarget.com/Service.asmx</a:To>
      <o:Security xmlns:o="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" s:mustUnderstand="1">
         <u:Timestamp u:Id="_0">
            <u:Created>2018-03-25T23:53:44.245Z</u:Created>
            <u:Expires>2018-03-25T23:58:44.245Z</u:Expires>
         </u:Timestamp>
         <o:UsernameToken u:Id="uuid-e54de35d-dc40-4b51-a5b6-e4b9ada9d32f-1">
            <o:Username>******</o:Username>
            <o:Password>*********</o:Password>
         </o:UsernameToken>
      </o:Security>
   </s:Header>
   <s:Body xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <ScheduleRequestMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
         <Options>
            <Client>
               <ID>****310</ID>
            </Client>
            <ScheduledTime>2018-03-25T20:53:23.2236156-03:00</ScheduledTime>
         </Options>
         <Action>start</Action>
         <Schedule>
            <Client>
               <ID>****310</ID>
            </Client>
            <PartnerKey xsi:nil="true" />
            <ObjectID xsi:nil="true" />
            <Recurrence xsi:type="HourlyRecurrence">
               <HourlyRecurrencePatternType>Interval</HourlyRecurrencePatternType>
               <HourInterval>1</HourInterval>
            </Recurrence>
            <RecurrenceType>Hourly</RecurrenceType>
            <RecurrenceRangeType>EndOn</RecurrenceRangeType>
            <StartDateTime>2018-03-25T20:53:23.2236156-03:00</StartDateTime>
            <EndDateTime>2038-03-25T20:53:23.2236156-03:00</EndDateTime>
            <TimeZone>
               <Client>
                  <ID>****310</ID>
               </Client>
               <PartnerKey xsi:nil="true" />
               <ID>86</ID>
               <ObjectID xsi:nil="true" />
            </TimeZone>
         </Schedule>
         <Interactions>
            <Interaction xsi:type="Automation">
               <Client>
                  <ID>****310</ID>
               </Client>
               <PartnerKey xsi:nil="true" />
               <ObjectID>f739bb44-ce04-4f36-ac4b-f946d9732a6c</ObjectID>
               <CustomerKey>0da20508-b3e4-4c4a-864e-2b351602c40d</CustomerKey>
            </Interaction>
         </Interactions>
      </ScheduleRequestMsg>
   </s:Body>
</s:Envelope>

RESPONSE

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
<soap:Header>
<wsa:Action>ScheduleResponse</wsa:Action>
<wsa:MessageID>urn:uuid:80146f80-0cbe-44eb-94f7-cc3edd1067fb</wsa:MessageID>
<wsa:RelatesTo>urn:uuid:009a92da-042d-4ff9-bf80-0bbc66cd13c1</wsa:RelatesTo>
<wsa:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</wsa:To>
<wsse:Security>
<wsu:Timestamp wsu:Id="Timestamp-3ed5d884-1489-4230-b2ad-9640dc53db79">
<wsu:Created>2018-03-25T23:53:46Z</wsu:Created>
<wsu:Expires>2018-03-25T23:58:46Z</wsu:Expires>
</wsu:Timestamp>
</wsse:Security>
</soap:Header>
<soap:Body>
<ScheduleResponseMsg xmlns="http://exacttarget.com/wsdl/partnerAPI">
<Results>
<Result>
<StatusCode>OK</StatusCode>
<StatusMessage>Program scheduled.</StatusMessage>
<RequestID>a2f695ec-e6ef-442f-8cea-0f089c8f5367</RequestID>
<Object>
<Client>
<ID>****310</ID>
</Client>
<PartnerKey xsi:nil="true" />
<ObjectID xsi:nil="true" />
<Recurrence xsi:type="HourlyRecurrence">
<HourlyRecurrencePatternType>Interval</HourlyRecurrencePatternType>
<HourInterval>1</HourInterval>
</Recurrence>
<RecurrenceType>Hourly</RecurrenceType>
<RecurrenceRangeType>EndOn</RecurrenceRangeType>
<StartDateTime>2018-03-25T17:53:23.2236156-06:00</StartDateTime>
<EndDateTime>2038-03-25T17:53:23.2236156-06:00</EndDateTime>
<TimeZone>
<Client>
<ID>****310</ID>
</Client>
<PartnerKey xsi:nil="true" />
<ID>86</ID>
<ObjectID xsi:nil="true" />
</TimeZone>
</Object>
<Task />
</Result>
</Results>
<OverallStatus>OK</OverallStatus>
<OverallStatusMessage />
<RequestID>300b5b27-dbbc-410a-aef6-bdf6fc85ab11</RequestID>
</ScheduleResponseMsg>
</soap:Body>
</soap:Envelope>
  • I have had success using a Fuel oAuth token for Soap Authentication in lieu of the Username/Password authentication. I have seen multiple Soap calls where the username/password return an OK response without the expected result while making the same Soap call using a fuel token returns the expected results. – Mike Mar 26 '18 at 20:05
1

I have had success using a Fuel oAuth token for Soap Authentication in lieu of the Username/Password authentication.

I have seen multiple Soap calls where the username/password return an OK response without the expected result while making the same Soap call using a fuel token returns the expected results.

Also, I seem to recall reading a response stating the behavior that in order to make certain (maybe all?) calls using child business units one must use the fueloauth authentication rather than the username/password in your example. I believe I have experienced this behavior myself, as well.

You would use in your header:

<a:fueloauth><![CDATA[{token}]]></a:fueloauth>

instead of:

<o:Security xmlns:o="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd&quot; s:mustUnderstand="1"> <u:Timestamp u:Id="_0"> <u:Created>2018-03-25T23:53:44.245Z</u:Created> <u:Expires>2018-03-25T23:58:44.245Z</u:Expires> </u:Timestamp> <o:UsernameToken u:Id="uuid-e54de35d-dc40-4b51-a5b6-e4b9ada9d32f-1"> <o:Username>******</o:Username> <o:Password>*********</o:Password> </o:UsernameToken> </o:Security> 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.