2

I noticed all of system.debug messages are not showing up on the debug-logs, since past few days. I even added debug msg at first line and the last line in constructor. Surprisingly, it did not displayed the first debug statement but displayed the one at last line.

Also, from 3 of my methods, I see none of the debug messages are getting displayed for 2 of the methods. however, debug messages of 3rd method are all getting displayed. The code is getting called, no doubt since I'm getting the List/Maps whatever I'm trying to create in the methods.

I also tried adding try-catch to check if any exception is preventing the debug messages but no luck.

Seems like Salesforce issue ? Has anyone experienced this ?

  • 1
    Have you tried changing the logging level to be error and setting all the system.debug's to be error level? – TimChadwick Nov 25 '13 at 15:10
  • Managing large debug logs can be assisted by reducing 'noise' in the log. For one approach, see salesforce.stackexchange.com/a/11251/2602 – cropredy Nov 25 '13 at 18:01
7

It seems they changed how large logs are handled. Instead of cutting them when they get to 2MB, they cut the first part and show the last 2MB (1.85 it seems). Check if you have something like Skipped xx bytes of detailed log in the very start of your log. This baffled me last week because I just used filtering to show debugs.

In any case, in filtering, you can drop anything you don't care about and leave Apex code at debug.

  • For me, it doesn't even allow me changing the filters. I save the changes but they are not reflected back. Does anyone else have the same problem? – RajeshShah Mar 25 '14 at 7:56
  • RajeshShah - from Monitoring | Debug Logs - delete the entry for yourself, even if there are logs left to be created, then recreate with the filters you want. – cropredy Sep 19 '14 at 1:12
0

Change the filter and save but make sure you dont reset the filters. if you reset the filters it reset to default again. Just refresh the page if you want to see new logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.